Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
Browse files
🐧🔧 Prevent plugin from installing with cordova-android >= 6.3.0
The code used in this plugin has been merged into cordova-android 6.3.0 so the
plugin should not be installed in projects usign 6.3.0 or later.
  • Loading branch information
macdonst committed Aug 11, 2017
1 parent f0c9644 commit 1ffe8394e4598925af945e9fb14a4389cca8a4f3
Showing 2 changed files with 15 additions and 5 deletions.
@@ -21,12 +21,17 @@
"ecosystem:phonegap",
"cordova-android"
],
"engines": [
{
"name": "cordova",
"version": ">=5.0.0"
"engines": {
"cordovaDependencies": {
"<1.2.0": {
"cordova": ">=5.0.0"
},
"1.2.0": {
"cordova": ">=5.0.0",
"cordova-android": "<6.3.0"
}
],
}
},
"author": "Apache Software Foundation",
"license": "Apache-2.0"
}
@@ -28,6 +28,11 @@
<keywords>cordova,compat</keywords>
<repo>https://git-wip-us.apache.org/repos/asf/cordova-plugin-compat.git</repo>

<engines>
<engine name="cordova" version=">=5.0.0"/>
<engine name="cordova-android" version="<6.3.0"/>

This comment has been minimized.

Copy link
@arumsey

arumsey Apr 18, 2018

Just an FYI - < is an invalid XML attribute value and causes strict XML parsers to fail.

</engines>

<!-- android -->
<platform name="android">
<source-file src="src/android/PermissionHelper.java" target-dir="src/org/apache/cordova" />

0 comments on commit 1ffe839

Please sign in to comment.