Skip to content
Permalink
Browse files
CB-11795 Add 'protective' entry to cordovaDependencies
The entry is required to protect end-users from fetching edge versions of the plugin by incompatible version of cordova. This also assumes that we will not introduce any regressions in compatibility w/ cordova in minor and patch releases. On every major release we will need to add similar entry with _next_ major version.

 This closes #194
  • Loading branch information
vladimir-kotikov authored and sgrebnov committed Sep 8, 2016
1 parent 9ad67e6 commit 719da363e77660c060b2fa6ed5486858e21f9da0
Showing 1 changed file with 7 additions and 0 deletions.
@@ -44,6 +44,13 @@
},
"author": "Apache Software Foundation",
"license": "Apache-2.0",
"engines": {
"cordovaDependencies": {
"5.0.0": {
"cordova": ">100"
}
}
},
"devDependencies": {
"jshint": "^2.6.0"
}

1 comment on commit 719da36

@ZaDarkSide
Copy link

@ZaDarkSide ZaDarkSide commented on 719da36 Feb 17, 2017

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Running cordova plugin add cordova-plugin-file
Will throw Error: Unexpected token } in JSON at position 710

Please sign in to comment.