Skip to content
Permalink
Browse files
Update python versions to 2.7/3.4, Replace latex_paper_size
Sphinx requires python 2.7/3.4 or higher.
Latex_paper_size property is deprecated, replace with latex_elements.papersize

According to the latest failed builds, sphinx needs at least Python 2.7 or 3.4 to build.
  • Loading branch information
padyx committed Jan 10, 2017
1 parent 59a887a commit 78ad53d7cc5760e09f90b5b1e3f2ba2d8d11bc3e
Showing 3 changed files with 6 additions and 6 deletions.
@@ -1,7 +1,7 @@
language: python
python:
- 2.6
- 3.3
- 2.7
- 3.4

before_install:
- sudo apt-get update -qq
@@ -17,7 +17,7 @@ MAKEINFO := makeinfo

BUILDDIR := build
SOURCE := src/
PAPERSIZE := -D latex_paper_size=a4
PAPERSIZE := -D latex_elements.papersize=a4
SPHINXFLAGS := -a -W -n -A local=1 $(PAPERSIZE) -d $(BUILDDIR)/doctree
SPHINXOPTS := $(SPHINXFLAGS) $(SOURCE)

@@ -7,14 +7,14 @@ if "%SPHINXBUILD%" == "" (
)
set BUILDDIR=build
set SOURCE=src/
set PAPERSIZE=-D latex_paper_size=a4
set PAPERSIZE=-D latex_elements.papersize=a4
set SPHINXFLAGS=-a -n -A local=1 %PAPERSIZE%
set SPHINXOPTS=%SPHINXFLAGS% %SOURCE%
set ALLSPHINXOPTS=-d %BUILDDIR%/doctrees %SPHINXOPTS%
set I18NSPHINXOPTS=%SPHINXOPTS%
if NOT "%PAPER%" == "" (
set ALLSPHINXOPTS=-D latex_paper_size=%PAPER% %ALLSPHINXOPTS%
set I18NSPHINXOPTS=-D latex_paper_size=%PAPER% %I18NSPHINXOPTS%
set ALLSPHINXOPTS=-D latex_elements.papersize=%PAPER% %ALLSPHINXOPTS%
set I18NSPHINXOPTS=-D latex_elements.papersize=%PAPER% %I18NSPHINXOPTS%
)

if "%1" == "" goto help

0 comments on commit 78ad53d

Please sign in to comment.