Permalink
Browse files

docs: update supported Erlang/OTP and SpiderMonkey versions

- matches what the code can support after last Mochiweb update
- update .travis.yml file to match 17.0 release
- update docs
  • Loading branch information...
1 parent 37af761 commit 1a0822862c2410143f3d2a4a508d72520e8f21a7 @dch dch committed with kxepal Apr 28, 2014
View
5 .travis.yml
@@ -4,7 +4,7 @@ before_install:
- sudo apt-get -y install libtool automake autoconf autoconf-archive
- sudo apt-get -y install texlive-latex-base texlive-latex-recommended
- sudo apt-get -y install texlive-latex-extra texlive-fonts-recommended texinfo
- - sudo apt-get -y install python-pygments python-docutils python-sphinx
+ - sudo apt-get -y install python-pygments python-docutils python-sphinx
before_script: ./bootstrap && ./configure
script:
- make distcheck
@@ -13,6 +13,7 @@ script:
- grunt test
language: erlang
otp_release:
- - R16B
+ - 17.0
+ - R16B03-1
- R15B03
- R14B04
View
4 INSTALL.Unix
@@ -39,10 +39,10 @@ Dependencies
You should have the following installed:
- * Erlang OTP (>=R13B04, <R17) (http://erlang.org/)
+ * Erlang OTP (>=R14B01, =<R17) (http://erlang.org/)
* ICU (http://icu-project.org/)
* OpenSSL (http://www.openssl.org/)
- * Mozilla SpiderMonkey (1.7) (http://www.mozilla.org/js/spidermonkey/)
+ * Mozilla SpiderMonkey (1.8.5) (http://www.mozilla.org/js/spidermonkey/)
* GNU Make (http://www.gnu.org/software/make/)
* GNU Compiler Collection (http://gcc.gnu.org/)
* libcurl (http://curl.haxx.se/libcurl/)
View
3 share/doc/build/Makefile.am
@@ -161,6 +161,7 @@ html_files = \
html/_sources/whatsnew/1.4.txt \
html/_sources/whatsnew/1.5.txt \
html/_sources/whatsnew/1.6.txt \
+ html/_sources/whatsnew/1.7.txt \
html/_sources/whatsnew/index.txt \
html/_sources/about.txt \
html/_sources/contents.txt \
@@ -283,6 +284,7 @@ html_files = \
html/whatsnew/1.4.html \
html/whatsnew/1.5.html \
html/whatsnew/1.6.html \
+ html/whatsnew/1.7.html \
html/whatsnew/index.html \
html/about.html \
html/config-ref.html \
@@ -432,6 +434,7 @@ src_files = \
../src/whatsnew/1.4.rst \
../src/whatsnew/1.5.rst \
../src/whatsnew/1.6.rst \
+ ../src/whatsnew/1.7.rst \
../src/whatsnew/index.rst \
../src/about.rst \
../src/contents.rst \
View
4 share/doc/src/install/unix.rst
@@ -52,10 +52,10 @@ Dependencies
You should have the following installed:
-* `Erlang OTP (>=R13B04, <R17) <http://erlang.org/>`_
+* `Erlang OTP (>=R14B01, =<R17) <http://erlang.org/>`_
* `ICU <http://icu-project.org/>`_
* `OpenSSL <http://www.openssl.org/>`_
-* `Mozilla SpiderMonkey (1.7) <http://www.mozilla.org/js/spidermonkey/>`_
+* `Mozilla SpiderMonkey (1.8.5) <http://www.mozilla.org/js/spidermonkey/>`_
* `GNU Make <http://www.gnu.org/software/make/>`_
* `GNU Compiler Collection <http://gcc.gnu.org/>`_
* `libcurl <http://curl.haxx.se/libcurl/>`_
View
42 share/doc/src/whatsnew/1.7.rst
@@ -0,0 +1,42 @@
+.. Licensed under the Apache License, Version 2.0 (the "License"); you may not
+.. use this file except in compliance with the License. You may obtain a copy of
+.. the License at
+..
+.. http://www.apache.org/licenses/LICENSE-2.0
+..
+.. Unless required by applicable law or agreed to in writing, software
+.. distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+.. WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+.. License for the specific language governing permissions and limitations under
+.. the License.
+
+
+.. _release/1.7.x:
+
+============
+1.7.x Branch
+============
+
+.. contents::
+ :depth: 1
+ :local:
+
+.. _release/1.7.x/upgrade:
+
+Upgrade Notes
+=============
+
+None.
+
+.. _release/1.7.0:
+
+Version 1.7.0
+=============
+
+.. warning::
+
+ This version is not released yet.
+
+* Build System: :issue:`2200`: support Erlang/OTP 17.0
+ :commit:`78603ad`
+
View
1 share/doc/src/whatsnew/index.rst
@@ -19,6 +19,7 @@ Release History
.. toctree::
:glob:
+ 1.7
1.6
1.5
1.4

0 comments on commit 1a08228

Please sign in to comment.