Permalink
Browse files

Require Erlang R13B04 or later

  • Loading branch information...
janl committed Dec 5, 2012
1 parent 8e88885 commit c20240cb455c7ecb67924582b433943b435cb106
Showing with 6 additions and 6 deletions.
  1. +2 −2 INSTALL.Unix
  2. +4 −4 configure.ac
View
@@ -25,7 +25,7 @@ Dependencies
You should have the following installed:
- * Erlang OTP (>=R12B5) (http://erlang.org/)
+ * Erlang OTP (>=R13B04) (http://erlang.org/)
* ICU (http://icu.sourceforge.net/)
* OpenSSL (http://www.openssl.org/)
* Mozilla SpiderMonkey (1.7) (http://www.mozilla.org/js/spidermonkey/)
@@ -34,7 +34,7 @@ You should have the following installed:
* libcurl (http://curl.haxx.se/libcurl/)
* help2man (http://www.gnu.org/s/help2man/)
-It is recommended that you install Erlang OTP R12B-5 or above where possible.
+It is recommended that you install Erlang OTP R13B-4 or above where possible.
You will only need libcurl if you plan to run the JavaScript test suite. And
help2man is only need if you plan on installing the CouchDB man pages.
View
@@ -374,20 +374,20 @@ case "$(uname -s)" in
esac
-erlang_version_error="The installed Erlang version is less than 5.6.5 (R12B05)."
+erlang_version_error="The installed Erlang version is less than 5.7.4 (R13B04)."
version="`${ERL} -version 2>&1 | ${SED} 's/[[^0-9]]/ /g'`"
if test `echo $version | ${AWK} "{print \\$1}"` -lt 5; then
AC_MSG_ERROR([$erlang_version_error])
fi
-if test `echo $version | ${AWK} "{print \\$2}"` -lt 6; then
+if test `echo $version | ${AWK} "{print \\$2}"` -lt 7; then
AC_MSG_ERROR([$erlang_version_error])
fi
-if test `echo $version | ${AWK} "{print \\$2}"` -eq 6; then
- if test `echo $version | ${AWK} "{print \\$3}"` -lt 5; then
+if test `echo $version | ${AWK} "{print \\$2}"` -eq 7; then
+ if test `echo $version | ${AWK} "{print \\$3}"` -lt 4; then
AC_MSG_ERROR([$erlang_version_error])
fi
fi

0 comments on commit c20240c

Please sign in to comment.