Skip to content
Permalink
Browse files
Update to JDK9 in order to work with new log4j2
  • Loading branch information
ottlinger committed Dec 15, 2020
1 parent f66a79f commit 982721d7bb3f0c7533f76f587921a4eeb4b6434a
Showing 2 changed files with 18 additions and 8 deletions.
@@ -3,10 +3,10 @@
[![ASF Build Status](https://ci-builds.apache.org/job/Creadur/job/Creadur-Tentacles/badge/icon)](https://ci-builds.apache.org/job/Creadur/job/Creadur-Tentacles/)
[![Travis Build Status](https://api.travis-ci.com/apache/creadur-tentacles.svg?branch=master)](https://travis-ci.com/apache/creadur-tentacles)

# Running
# Running with JDK9

The tool will download all the archives from a staging repo, unpack
them and create a little report of what is there.
them and create a little report of what is there.

java -ea -jar apache-tentacles-0.1-SNAPSHOT.jar https://repository.apache.org/content/repositories/orgapacheopenejb-090

22 pom.xml
@@ -50,9 +50,14 @@
<version>2.4.2</version>
</dependency>
<dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
<version>1.2.17</version>
<groupId>org.apache.logging.log4j</groupId>
<artifactId>log4j-api</artifactId>
<version>2.14.0</version>
</dependency>
<dependency>
<groupId>org.apache.logging.log4j</groupId>
<artifactId>log4j-core</artifactId>
<version>2.14.0</version>
</dependency>
<dependency>
<groupId>org.apache.velocity</groupId>
@@ -73,7 +78,7 @@
</dependencies>
<properties>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<javaVersion>1.8</javaVersion>
<javaVersion>9</javaVersion>
<httpClientVersion>4.3.6</httpClientVersion>
<apacheRatVersion>0.13</apacheRatVersion>
</properties>
@@ -106,6 +111,7 @@
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.8.1</version>
<configuration>
<source>${javaVersion}</source>
<target>${javaVersion}</target>
@@ -114,6 +120,7 @@
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-enforcer-plugin</artifactId>
<version>3.0.0-M3</version>
<executions>
<execution>
<!-- This checks the bytecode version of the dependencies transitively -->
@@ -126,6 +133,9 @@
<enforceBytecodeVersion>
<maxJdkVersion>${javaVersion}</maxJdkVersion>
</enforceBytecodeVersion>
<requireMavenVersion>
<version>3.0.5</version>
</requireMavenVersion>
</rules>
<fail>true</fail>
</configuration>
@@ -151,15 +161,15 @@
be changed manually when we decide to move to a higher version of
Java
-->
<id>check-java-1.8-compat</id>
<id>check-java-1.9-compat</id>
<phase>process-classes</phase>
<goals>
<goal>check</goal>
</goals>
<configuration>
<signature>
<groupId>org.codehaus.mojo.signature</groupId>
<artifactId>java18</artifactId>
<artifactId>java9</artifactId>
<version>1.0</version>
</signature>
</configuration>

0 comments on commit 982721d

Please sign in to comment.