Skip to content
Permalink
Browse files
Merge pull request #54 from apache/backport_9008
Backport Docs: bold Java 8 requirement #9008
  • Loading branch information
jon-wei committed Dec 10, 2019
2 parents 40ee066 + f7828c2 commit 3af3ec2e3de7a846ba2b6d774c252fff050816b3
Showing 2 changed files with 8 additions and 2 deletions.
@@ -145,8 +145,11 @@ <h4><a class="anchor" aria-hidden="true" id="query-server-1"></a><a href="#query
<h2><a class="anchor" aria-hidden="true" id="select-os"></a><a href="#select-os" aria-hidden="true" class="hash-link"><svg class="hash-link-icon" aria-hidden="true" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Select OS</h2>
<p>We recommend running your favorite Linux distribution. You will also need:</p>
<ul>
<li>Java 8</li>
<li><strong>Java 8</strong></li>
</ul>
<blockquote>
<p><strong>Warning:</strong> Java 8 is required to run Druid. While Druid will start with a higher version of Java it will not function correctly.</p>
</blockquote>
<p>Your OS package manager should be able to help for both Java. If your Ubuntu-based OS
does not have a recent enough version of Java, WebUpd8 offers <a href="http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html">packages for those
OSes</a>.</p>
@@ -85,9 +85,12 @@ <h2><a class="anchor" aria-hidden="true" id="prerequisites"></a><a href="#prereq
<h3><a class="anchor" aria-hidden="true" id="software"></a><a href="#software" aria-hidden="true" class="hash-link"><svg class="hash-link-icon" aria-hidden="true" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Software</h3>
<p>You will need:</p>
<ul>
<li>Java 8 (8u92+)</li>
<li><strong>Java 8 (8u92+)</strong></li>
<li>Linux, Mac OS X, or other Unix-like OS (Windows is not supported)</li>
</ul>
<blockquote>
<p><strong>Warning:</strong> Java 8 is required to run Druid. While Druid will start with a higher version of Java it will not function correctly.</p>
</blockquote>
<h3><a class="anchor" aria-hidden="true" id="hardware"></a><a href="#hardware" aria-hidden="true" class="hash-link"><svg class="hash-link-icon" aria-hidden="true" height="16" version="1.1" viewBox="0 0 16 16" width="16"><path fill-rule="evenodd" d="M4 9h1v1H4c-1.5 0-3-1.69-3-3.5S2.55 3 4 3h4c1.45 0 3 1.69 3 3.5 0 1.41-.91 2.72-2 3.25V8.59c.58-.45 1-1.27 1-2.09C10 5.22 8.98 4 8 4H4c-.98 0-2 1.22-2 2.5S3 9 4 9zm9-3h-1v1h1c1 0 2 1.22 2 2.5S13.98 12 13 12H9c-.98 0-2-1.22-2-2.5 0-.83.42-1.64 1-2.09V6.25c-1.09.53-2 1.84-2 3.25C6 11.31 7.55 13 9 13h4c1.45 0 3-1.69 3-3.5S14.5 6 13 6z"></path></svg></a>Hardware</h3>
<p>Druid includes several example <a href="/docs/0.16.0-incubating/operations/single-server.html">single-server configurations</a>, along with scripts to
start the Druid processes using these configurations.</p>

0 comments on commit 3af3ec2

Please sign in to comment.