Skip to content
Permalink
Browse files
Allow use of Hadoop 3.x with Accumulo 1.10.x in uno.conf (#260)
Update version sanity check to allow Hadoop 3.x to be used with Accumulo
versions 1.10 and greater.
  • Loading branch information
jmark99 committed Oct 14, 2020
1 parent a639803 commit 6a7c30939b0c6e1050e729b652d994b9d7e7d2e9
Showing 1 changed file with 2 additions and 3 deletions.
@@ -96,14 +96,13 @@ fi
# work with Hadoop 3.x. The following sanity checks fail fast when versions
# are incompatible. If the checks cause a problem, comment them out and
# consider submitting an issue or PR.

if [[ "${HADOOP_VERSION}" = 1.* ]]; then
echo "ERROR from uno.conf : Hadoop 1.x is not supported" 1>&2
exit 1
fi

if [[ -z "$ACCUMULO_REPO" && "${ACCUMULO_VERSION}" = 1.* && ! "${HADOOP_VERSION}" = 2.* ]]; then
echo "ERROR from uno.conf : When using Accumulo 1.x, expect Hadoop 2.x not $HADOOP_VERSION" 1>&2
if [[ -z $ACCUMULO_REPO && ${ACCUMULO_VERSION} =~ ^1[.][0-9][.][0-9]+$ && ! ${HADOOP_VERSION} = 2.* ]]; then
echo "ERROR from uno.conf : When using Accumulo versions prior to 1.10.x, expect Hadoop 2.x not $HADOOP_VERSION" 1>&2
exit 1
fi

0 comments on commit 6a7c309

Please sign in to comment.