Skip to content
Permalink
Browse files
update versions in security policy
  • Loading branch information
paulk-asert committed Mar 24, 2022
1 parent cfdc3bc commit 0905af87e3ac99db7b4d434b6ee0c53e73ab5423
Showing 1 changed file with 11 additions and 4 deletions.
@@ -18,17 +18,24 @@ limitations under the License.

## Supported Versions

The latest released version in the Groovy 3.0.x stream of releases
The latest released version in the Groovy 4.0.x stream of releases
is the currently recommended version of Groovy and requires JDK8 as a minimum.

The latest released version in the Groovy 3.0.x stream of releases
is the currently recommended version of Groovy if you require access
to the legacy parser or legacy packages of classes whose packages
were renamed due to split package remediation ([GROOVY-10542](https://issues.apache.org/jira/browse/GROOVY-10542)).

The latest released version in the Groovy 2.5.x stream is recommended where JDK7 is required.

| Version | Supported | Comment |
| -------- | ------------------ | ---------------------------------------- |
|----------| ------------------ |------------------------------------------|
| <= 2.3.x | :x: | |
| 2.4.x | :grey_question: | Only severe/critical vulnerabilities (*) |
| 2.5.x | :white_check_mark: | |
| 2.5.x | :white_check_mark: | Reduced releases on this branch |
| 3.0.x | :white_check_mark: | |
| 4.x | :grey_question: | Pre-release status (**) |
| 4.0.x | :white_check_mark: | |
| 5.x | :grey_question: | Pre-release status (**) |

(\*) The 2.4.x stream is no longer the focus of the core team
but critical security fixes or community contributions may lead

0 comments on commit 0905af8

Please sign in to comment.