Skip to content
Permalink
Browse files
GROOVY-10507: Bump Spock to 2.1-groovy-3.0 (cont'd))
  • Loading branch information
paulk-asert committed Feb 24, 2022
1 parent 0d11c95 commit f9e3305d2147a40ade4c45f4234304f821cb06fc
Show file tree
Hide file tree
Showing 2 changed files with 4 additions and 1 deletion.
@@ -573,6 +573,9 @@
<artifact name="jcip-annotations-1.0.jar">
<sha512 value="cb312b3f571d91ef183c119d878f50464ffd97f853b7311cba386463f295e8b7b3a5a89ed4269a045cacd5aa7cb4c803d4882854a0fddefa9bbc28c72aa6c786" origin="Generated by Gradle because artifact wasn't signed"/>
</artifact>
<artifact name="jcip-annotations-1.0.pom">
<sha512 value="dfe1a3946e9381cc9b3619ba3149615dc63cb6790ccf0518d56242f4b74d0e6105dce24a40642bb8a79ab6ecdbe42eabc3ee51f752421dad5db9c894256bdf41" origin="Generated by Gradle because artifact wasn't signed"/>
</artifact>
</component>
<component group="net.sf.jopt-simple" name="jopt-simple" version="4.6">
<artifact name="jopt-simple-4.6.jar">
@@ -36,7 +36,7 @@ class ContractsSpec extends Specification {
@Requires({ dir && file && path })
private contractedMethod(String dir, String file, String path) { }

@spock.lang.Requires({ count < max })
@spock.lang.Requires({ data.count < data.max })
def "spock Requires annotation still works with groovy-contracts"(Integer count, Integer max) {
expect:
count < max

0 comments on commit f9e3305

Please sign in to comment.