Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

HBASE-23269 Hbase crashed due to two versions of regionservers when rolling upgrading #895

Closed
wants to merge 5 commits into from

Conversation

@xujianzhen
Copy link

xujianzhen commented Dec 3, 2019

HBASE-23269 Hbase crashed due to two versions of regionservers when rolling upgrading. JianzhenXu

@Apache-HBase

This comment has been minimized.

Copy link

Apache-HBase commented Dec 3, 2019

💔 -1 overall

Vote Subsystem Runtime Comment
+0 🆗 reexec 0m 0s Docker mode activated.
-1 patch 0m 10s #895 does not apply to branch-1.4. Rebase required? Wrong Branch? See https://yetus.apache.org/documentation/in-progress/precommit-patchnames for help.
Subsystem Report/Notes
GITHUB PR #895
JIRA Issue HBASE-23269
Console output https://builds.apache.org/job/HBase-PreCommit-GitHub-PR/job/PR-895/1/console
versions git=2.17.1
Powered by Apache Yetus 0.11.1 https://yetus.apache.org

This message was automatically generated.

@xujianzhen

This comment has been minimized.

Copy link
Author

xujianzhen commented Dec 3, 2019

@liuml07 Hi, Now I'm developing directly on the branch-1.4 of fork to my github, and then propose a pr, which is still error。How can i do it? The problem is same in #844

@xujianzhen

This comment has been minimized.

Copy link
Author

xujianzhen commented Dec 3, 2019

@apurtell Hi, I coding at branch-1.4 branch of forked in my github, and propose a pr to apache branch-1.4, but also prompt version issue。How can i do it? The problem is same in #844'

@xujianzhen xujianzhen changed the title HBASE-23269: Hbase crashed due to two versions of regionservers when rolling upgrading HBASE-23269 Hbase crashed due to two versions of regionservers when rolling upgrading Dec 3, 2019
@Apache-HBase

This comment has been minimized.

Copy link

Apache-HBase commented Dec 3, 2019

💔 -1 overall

Vote Subsystem Runtime Comment
+0 🆗 reexec 0m 0s Docker mode activated.
-1 patch 0m 9s #895 does not apply to branch-1.4. Rebase required? Wrong Branch? See https://yetus.apache.org/documentation/in-progress/precommit-patchnames for help.
Subsystem Report/Notes
GITHUB PR #895
Console output https://builds.apache.org/job/HBase-PreCommit-GitHub-PR/job/PR-895/2/console
versions git=2.17.1
Powered by Apache Yetus 0.11.1 https://yetus.apache.org

This message was automatically generated.

@xujianzhen xujianzhen closed this Dec 4, 2019
@xujianzhen xujianzhen reopened this Dec 4, 2019
@Apache-HBase

This comment has been minimized.

Copy link

Apache-HBase commented Dec 4, 2019

💔 -1 overall

Vote Subsystem Runtime Comment
+0 🆗 reexec 0m 0s Docker mode activated.
-1 patch 0m 9s #895 does not apply to branch-1.4. Rebase required? Wrong Branch? See https://yetus.apache.org/documentation/in-progress/precommit-patchnames for help.
Subsystem Report/Notes
GITHUB PR #895
Console output https://builds.apache.org/job/HBase-PreCommit-GitHub-PR/job/PR-895/3/console
versions git=2.17.1
Powered by Apache Yetus 0.11.1 https://yetus.apache.org

This message was automatically generated.

@liuml07

This comment has been minimized.

Copy link
Member

liuml07 commented Dec 4, 2019

I'm not sure about the root cause of error. I think it's suggested to file patches against master branch, even if you want to patch in another branch. When this patch is first committed to the master branch, the committer can backport to branch-1.4.

@xujianzhen xujianzhen closed this Dec 10, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.