Skip to content
Permalink
Browse files
HIVE-26226: Exclude jdk.tools dep from hive-metastore in upgrade-acid…
… (Sylwester Lachiewicz, reviewed by Stamatis Zampetakis)

The jdk.tools jars are not present in java versions > 8 thus there are
build problems when compiling with newer JDKs.

Exclude the dependency from hive-metastore (2.3.3) to avoid compilation
problems in recent JDKs.

It is safe to so because the dependency will still be fetched
transitively by hadoop-common (2.7.2) when the appropriate maven (JDK)
profile is in use.

Closes #3284
  • Loading branch information
slachiewicz authored and zabetak committed May 17, 2022
1 parent dfc3689 commit d9724ad765e38c2f29805a7d0a4660c5e467e3e7
Showing 1 changed file with 4 additions and 0 deletions.
@@ -71,6 +71,10 @@
<groupId>org.apache.curator</groupId>
<artifactId>curator-framework</artifactId>
</exclusion>
<exclusion>
<groupId>jdk.tools</groupId>
<artifactId>jdk.tools</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>

0 comments on commit d9724ad

Please sign in to comment.