Skip to content
Permalink
Browse files
Revert "Update Antora version"
This reverts commit 7abddb7.
  • Loading branch information
hansva committed Feb 3, 2022
1 parent 6f1babb commit bd0505ba61d09e68c7ec238e436130e3bd04bbc4
Show file tree
Hide file tree
Showing 5 changed files with 1,184 additions and 973 deletions.
@@ -1,4 +1,4 @@
FROM node:lts-bullseye
FROM node:lts-stretch

RUN set -ex \
&& apt-get update \
@@ -6,7 +6,7 @@ Tools used to generate the website:

- [Git](https://git-scm.com/) a source code management tool used to fetch document sources from different
github repositories.
- [Node.js](https://nodejs.org/) a JavaScript runtime used to build the website. You will need to use Node.js version 16.
- [Node.js](https://nodejs.org/) a JavaScript runtime used to build the website. You will need to use Node.js version 12.
- [yarn](https://yarnpkg.com/) a blazing fast dependency and package manager tool used to download
and manage required libraries.
- (installed via yarn) [Gulp](http://gulpjs.com/) a task automation tool. Used to build the Hop
@@ -33,7 +33,7 @@ Make sure that you have Node.js (herein "`Node`") installed.

If this command fails with an error, you do not have Node.js installed.

This project requires the Node LTS version 16 (e.g., V16.13.2).
This project requires the Node Maintenance LTS version 12 (e.g., V12.19.0).

Please make sure to have a suitable version of Node.js installed. You have several options to install
Node.js on your machine:
@@ -42,12 +42,12 @@ Node.js on your machine:
- Install using [Homebrew](https://brew.sh/) and [Node formulae](https://formulae.brew.sh/formula/node)
- Install from official [Node packages](https://nodejs.org/en/download/)

Note - If you have different Node version other than Node.js LTS version 16 you can use following command to make
Node.js LTS version 16 as your default Node.js version.
Note - If you have different Node version other than Node.js Maintenance LTS version 12 you can use following command to make
Node.js Maintenance LTS version 12 as your default Node.js version.

$ nvm alias default 16
$ nvm alias default 12

Now that you have Node 16 installed, you can proceed with checking the Yarn installation.
Now that you have Node 12 installed, you can proceed with checking the Yarn installation.

#### Yarn

@@ -18,9 +18,8 @@
"checks": "run-s check:*"
},
"devDependencies": {
"@antora/cli": "3.0.1",
"@antora/site-generator-default": "~3.0.1",
"@antora/site-generator": "~3.0.1",
"@antora/cli": "2.3",
"@antora/site-generator-default": "~2.3",
"gulp": "^4.0.2",
"gulp-htmlmin": "~5.0",
"html-validate": "~5.0.2",
@@ -33,9 +32,9 @@
"pnp": true
},
"dependencies": {
"asciidoctor": "^2.2.6",
"asciidoctor": "^2.0.15",
"cookies-eu-banner": "^2.0.1",
"handlebars": "~4.7.7",
"handlebars": "~4.4",
"toml": "~3.0",
"unzipper": "~0.10",
"yaml": "~1.7"
@@ -25,7 +25,7 @@ ui:
url: ./antora-ui-hop/build/ui-bundle.zip

urls:
latest_version_segment: stable
redirect_facility: disabled

output:
clean: true

0 comments on commit bd0505b

Please sign in to comment.