Permalink
Browse files

Make sure mod_access_compat is loaded for Apache 2.4

so that "allow from" style of ACLs in our config works.
Ref: #1229
  • Loading branch information...
morlovich committed Jan 20, 2016
1 parent d3851dd commit 02e8f7e866a1d8bd1ee28ee7d263770f6984d333
Showing with 8 additions and 0 deletions.
  1. +8 −0 install/common/pagespeed.load.template
@@ -7,6 +7,14 @@
LoadModule pagespeed_module @@APACHE_MODULEDIR@@/mod_pagespeed.so
</IfVersion>
<IfVersion >= 2.4.2>
# As default pagespeed.conf configuration uses old-style ACLs using
# 'allow' and 'deny', we load mod_access_compat in Apache 2.4. If that's a
# problem, the blocks using that can be converted to the newer 'Require'
# syntax.
<IfModule !access_compat_module>
LoadModule access_compat_module @@APACHE_MODULEDIR@@/mod_access_compat.so
</IfModule>

LoadModule pagespeed_module @@APACHE_MODULEDIR@@/mod_pagespeed_ap24.so
</IfVersion>

0 comments on commit 02e8f7e

Please sign in to comment.