Skip to content
This repository was archived by the owner on Apr 10, 2025. It is now read-only.
This repository was archived by the owner on Apr 10, 2025. It is now read-only.

Need documentation describing how to configure VirtualHost with mod_pagespeed #116

Description

@GoogleCodeExporter
What steps will reproduce the problem?
1. Comment out all of /etc/apache2/mods-enabled/pagespeed.conf, replacing with 
<IfModule pagespeed_module>ModPagespeed off</IfModule>
2. Include the former contents of pagespeed.conf into a single virtualhost
3. Attempt to access a non-pagespeed'd virtualhost

What is the expected output? What do you see instead?
I would expect modpagespeed to be disabled globally, but enabled only on 
specifically-configured virtualhosts

What version of the product are you using (please check X-Mod-Pagespeed
header)?
0.9.10.1-250

On what operating system?
Ubuntu Karmic (9.10)

Which version of Apache?
2.2.12-1ubuntu2.4

Which MPM?
mpm-worker

Please provide any additional information below, especially a URL or an
HTML file that exhibits the problem.
When I don't have "ModPagespeed off" in the pagespeed.conf, Apache fails to 
start with:

[Thu Nov 25 17:22:02 2010] [error] [mod_pagespeed 0.9.10.1-250] mod_pagespeed 
is enabled.  The following directives must not be 
NULL\nModPagespeedFileCachePath=\nModPagespeedGeneratedFilePrefix=\n

When I do have "ModPagespeed off" in the pagespeed.conf, Apache starts, but 
fails to serve pages for non-Pagespeed'd virtualhosts, with:

[Thu Nov 25 17:22:28 2010] [alert] [mod_pagespeed 0.9.10.1-250] 
[1125/172228:FATAL:net/instaweb/rewriter/rewrite_driver_factory.cc(205)] Check 
failed: !filename_prefix_.empty(). Must specify --filename_prefix or call 
RewriteDriverFactory::set_filename_prefix.\nBacktrace:\n\t/usr/lib/apache2/modul
es/mod_pagespeed.so 
[0x7fbfe7487dda]\n\t/usr/lib/apache2/modules/mod_pagespeed.so 
[0x7fbfe74796ad]\n\t/usr/lib/apache2/modules/mod_pagespeed.so 
[0x7fbfe7488c5d]\n\t/usr/lib/apache2/modules/mod_pagespeed.so 
[0x7fbfe74cec23]\n\t/usr/lib/apache2/modules/mod_pagespeed.so 
[0x7fbfe747c779]\n\t/usr/lib/apache2/modules/mod_pagespeed.so 
[0x7fbfe74cdf40]\n\t/usr/lib/apache2/modules/mod_pagespeed.so 
[0x7fbfe74ce03c]\n\t/usr/lib/apache2/modules/mod_pagespeed.so 
[0x7fbfe7478e76]\n\t/usr/sbin/apache2(ap_run_handler+0x70) 
[0x7fbfeb755310]\n\t/usr/sbin/apache2(ap_invoke_handler+0x98) 
[0x7fbfeb758c58]\n\t/usr/sbin/apache2(ap_process_request+0x1c8) 
[0x7fbfeb7664e8]\n\t/usr/sbin/apache2 
[0x7fbfeb7633c8]\n\t/usr/sbin/apache2(ap_run_process_connection+0x68) 
[0x7fbfeb75cea8]\n\t/usr/sbin/apache2 
[0x7fbfeb76bdd2]\n\t/usr/lib/libapr-1.so.0 
[0x7fbfeae942ff]\n\t/lib/libpthread.so.0 
[0x7fbfeac55a04]\n\t/lib/libc.so.6(clone+0x6d) [0x7fbfea9bed4d]

Original issue reported on code.google.com by rtuc...@gmail.com on 25 Nov 2010 at 5:36

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions