New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Serf depends on APR 1.3 #1224

Closed
fidoboy opened this Issue Dec 17, 2015 · 4 comments

Comments

Projects
None yet
3 participants
@fidoboy
Copy link

fidoboy commented Dec 17, 2015

Today i've updated to the latest beta (1.10.33.1-beta) and the pagespeed module fails to start, with this error message "undefined symbol: apr_sockaddr_ip_getbuf". I've rolled back to the previous stable version and it works fine again.

@morlovich

This comment has been minimized.

Copy link
Contributor

morlovich commented Dec 17, 2015

Could you tell us what libapr version you have installed?

On Thu, Dec 17, 2015 at 11:44 AM, fidoboy notifications@github.com wrote:

Today i've updated to the latest beta (110331-beta) and the pagespeed
module fails to start, with this error message "undefined symbol:
apr_sockaddr_ip_getbuf" I've rolled back to the previous stable version and
it works fine again


Reply to this email directly or view it on GitHub
#1224.

@fidoboy

This comment has been minimized.

Copy link

fidoboy commented Dec 17, 2015

APR 1.2.7

@morlovich

This comment has been minimized.

Copy link
Contributor

morlovich commented Dec 17, 2015

This seems to be used via Serf, and only in a debug method:
http://subversion.1072662.n5.nabble.com/Serf-1-2-0-has-been-released-td178523.html
Sounds like may be we should patch that out for .2 ?

On Thu, Dec 17, 2015 at 12:40 PM, fidoboy notifications@github.com wrote:

APR 1.2.7


Reply to this email directly or view it on GitHub
#1224 (comment)
.

@jeffkaufman

This comment has been minimized.

Copy link
Contributor

jeffkaufman commented Dec 17, 2015

I can do this.

@jeffkaufman jeffkaufman self-assigned this Dec 17, 2015

@jeffkaufman jeffkaufman changed the title Error thrown when starting httpd after last update Serf depends on APR 1.3 Dec 17, 2015

jeffkaufman added a commit that referenced this issue Dec 17, 2015

Remove our dependency on apr_sockaddr_ip_getbuf
The new version of serf uses apr_sockaddr_ip_getbuf to add IP addresses to log
messages, but this function is new in APR 1.3.  This means we get a runtime
error on CentOS 5, where Apache fails to start.

We didn't catch this on our buildbot because one of our dependencies needs to be
fetched over svn with svn 1.8 or higher, and installing the new svn brought
along a new apr (1.5) and everything worked.

Fixes #1224
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment