Skip to content
This repository has been archived by the owner on Apr 21, 2023. It is now read-only.

Wysiwyg 2.2 and CKEditor 3.5 on Drupal + mod_pagespeed breaks #186

Closed
GoogleCodeExporter opened this issue Apr 6, 2015 · 9 comments
Closed

Comments

@GoogleCodeExporter
Copy link

From http://drupal.org/node/1024316

Description
Wysiwyg 2.2 and CKEditor 3.5 (other editors affected?) on D6 seems to be 
incompatible with mod_pagespeed.

When I activate mod_pagespeed (the version installed by my host Dreamhost), the 
Wysiwyg module doesn't show any editor buttons as soon as the "Rich editor" is 
active. After disabling mod_pagespeed, everything goes back to normal.

See also http://drupal.org/node/962946 for a generic discussion on 
mod_pagespeed and Drupal. Thanks -

Original issue reported on code.google.com by sligocki@google.com on 12 Jan 2011 at 4:45

@GoogleCodeExporter
Copy link
Author

I'm not sure exactly which version Dreamhost is using.  Can we get a site URL 
exhibiting the bug?

Most likely this is the typical javascript-that-reads-its-own-script-src 
problem and we just need to have a ModPagespeedDisallow.

Original comment by jmara...@google.com on 14 Jan 2011 at 6:08

  • Changed state: RequestClarification

@GoogleCodeExporter
Copy link
Author

Another report: http://drupal.org/node/1088278

Original comment by sligocki@google.com on 11 Mar 2011 at 4:09

@GoogleCodeExporter
Copy link
Author

Another one: http://drupal.org/node/1095908

Original comment by sligocki@google.com on 17 Mar 2011 at 5:58

@GoogleCodeExporter
Copy link
Author

CKEditor bug tracker: http://dev.ckeditor.com/ticket/7511

Original comment by sligocki@google.com on 7 Apr 2011 at 5:40

@GoogleCodeExporter
Copy link
Author

Marked fixed upstream: http://drupal.org/node/1095908

Original comment by sligocki@google.com on 9 Sep 2011 at 7:21

  • Changed state: Fixed

@GoogleCodeExporter
Copy link
Author

Issue 361 has been merged into this issue.

Original comment by sligocki@google.com on 12 Dec 2011 at 3:06

@GoogleCodeExporter
Copy link
Author

Re-opening, this appears to still be a problem with latest ckeditor.js

Disallowing *ckeditor* by default.

Original comment by sligocki@google.com on 12 Dec 2011 at 4:37

  • Changed state: Started

@GoogleCodeExporter
Copy link
Author

This issue was closed by revision r1256.

Original comment by sligocki@google.com on 12 Dec 2011 at 6:11

  • Changed state: Fixed

@GoogleCodeExporter
Copy link
Author

Original comment by matterb...@google.com on 26 Jan 2012 at 3:05

  • Added labels: release-note

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Development

No branches or pull requests

1 participant