Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installation problems #7515

Closed
mgabrielis opened this issue May 15, 2019 · 2 comments

Comments

Projects
None yet
3 participants
@mgabrielis
Copy link

commented May 15, 2019

Trying to install--current setup:
Fedora 30 --> docker with CentOS --> pip venv --> Apache Superset

Errors:

  1. When installing OS dependencies, libsasl2-devel is not available
  2. When creating an admin account, "Was unable to import superset Error: the enfironment variable POSTGRES_USER was missing, abort...
  3. When running superset db upgrade, receive a traceback alert: from pandas.core.common import _maybe_box_datetimelike IImportError:cannot import name '_maybe_box_datetimelike' from 'pandas.core.common' (/root/incubator-superset/contrib/docker/venv/lib/python3.7/site-packages/pandas/core/common.py)
    3a) pandas is already installed

Please let me know what I can do to keep rolling. Thanks!

@issue-label-bot issue-label-bot bot added the #bug label May 15, 2019

@issue-label-bot

This comment has been minimized.

Copy link

commented May 15, 2019

Issue-Label Bot is automatically applying the label #bug to this issue, with a confidence of 0.53. Please mark this comment with 👍 or 👎 to give our bot feedback!

Links: app homepage, dashboard and code for this bot.

@thenooz

This comment has been minimized.

Copy link

commented May 17, 2019

Just do, pip install pandas==0.23.4
From the solution here: #6770 (comment)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.