Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix ExtDeprecationWarning (#2137) #2138

Merged
merged 2 commits into from Feb 8, 2017

Conversation

@asdf2014
Copy link
Member

commented Feb 8, 2017

Fix ExtDeprecationWarning (#2137)

@asdf2014

This comment has been minimized.

Copy link
Member Author

commented Feb 8, 2017

Why re-check the code, i just amend the commit message for adding the issues code?

@mistercrunch

This comment has been minimized.

Copy link
Contributor

commented Feb 8, 2017

I'm fine turning off these warnings. They're coming from the libs we use and therefore they need to fix those. Since our deps are pinned it shouldn't be an issue.

@mistercrunch mistercrunch merged commit 1edc2b9 into apache:master Feb 8, 2017

4 checks passed

code-quality/landscape Code quality remained the same
Details
codeclimate no new or fixed issues
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
coverage/coveralls Coverage remained the same at 80.56%
Details

@asdf2014 asdf2014 deleted the asdf2014:ext_deprecation_warning branch Feb 9, 2017

@asdf2014

This comment has been minimized.

Copy link
Member Author

commented Feb 9, 2017

Yeah, it is.

@uptonking

This comment has been minimized.

Copy link

commented Feb 11, 2017

@asdf2014 @mistercrunch before I merge this commit, superset works fine.. after this commit, I got an error.

Traceback (most recent call last):
  File "/usr/bin/superset", line 6, in <module>
    exec(compile(open(__file__).read(), __file__, 'exec'))
  File "/root/Documents/repos/supersetx/superset/bin/superset", line 8, in <module>
    from flask.exthook import ExtDeprecationWarning
ImportError: cannot import name ExtDeprecationWarning

my env is Pyhton2.7, when I look for ExtDeprecationWarning in `path/to/site-packages/flask/exthook.py, it doesn't exist.
any advice?

@asdf2014

This comment has been minimized.

Copy link
Member Author

commented Feb 11, 2017

Hi, @uptonking . I use python 2.7.12 and it works for me. Could you run pip freeze command in your venv, show those requirements in comment?

@asdf2014

This comment has been minimized.

Copy link
Member Author

commented Feb 11, 2017

I think you should reinstall the Flask.
pip freeze | grep Flask

Flask==0.12
Flask-AppBuilder==1.8.1
Flask-Babel==0.11.1
Flask-Cache==0.13.1
Flask-Login==0.2.11
Flask-Migrate==1.5.1
Flask-OpenID==1.2.5
Flask-Script==2.0.5
Flask-SQLAlchemy==2.0
Flask-Testing==0.5.0
Flask-WTF==0.14.2

The requirement ** Flask==0.10 ** does not look good...

@asdf2014

This comment has been minimized.

Copy link
Member Author

commented Feb 11, 2017

@uptonking

This comment has been minimized.

Copy link

commented Feb 11, 2017

@asdf2014 thanks. superset nice again 👍

@asdf2014

This comment has been minimized.

Copy link
Member Author

commented Feb 11, 2017

Congratulations! And u r welcome :D

robert-digit added a commit to robert-digit/superset that referenced this pull request Feb 13, 2017

Fix ExtDeprecationWarning (apache#2137) (apache#2138)
* fix ExtDeprecationWarning (apache#2137)

* remove warnings.simplefilter from cli.py into superset for PEP (apache#2137)

rlei added a commit to rlei/superset that referenced this pull request Feb 24, 2017

Fix ExtDeprecationWarning (apache#2137) (apache#2138)
* fix ExtDeprecationWarning (apache#2137)

* remove warnings.simplefilter from cli.py into superset for PEP (apache#2137)

SalehHindi pushed a commit to SalehHindi/superset that referenced this pull request Jun 9, 2017

Fix ExtDeprecationWarning (apache#2137) (apache#2138)
* fix ExtDeprecationWarning (apache#2137)

* remove warnings.simplefilter from cli.py into superset for PEP (apache#2137)

SalehHindi pushed a commit to SalehHindi/superset that referenced this pull request Jun 9, 2017

Fix ExtDeprecationWarning (apache#2137) (apache#2138)
* fix ExtDeprecationWarning (apache#2137)

* remove warnings.simplefilter from cli.py into superset for PEP (apache#2137)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.