Skip to content
Permalink
Browse files

Fixed: Make ‘javadoc’ build work with recent Java

(OFBIZ-11257)

With a recent OpenJDK release we had the following error

```
> Task :javadoc
javadoc: error - The code being documented uses modules but the packages defined in https://docs.oracle.com/javase/8/docs/api/ are in the unnamed module.
javadoc: error - The code being documented uses modules but the
packages defined in https://docs.oracle.com/javaee/7/api/ are in the
unnamed module.
[...]
2 errors
100 warnings

> Task :javadoc FAILED
```

With ‘javadoc --source 8’ this error disappears as described in
JDK-8212233 [1].

[1] https://bugs.openjdk.java.net/browse/JDK-8212233


git-svn-id: https://svn.apache.org/repos/asf/ofbiz/ofbiz-framework/trunk@1868622 13f79535-47bb-0310-9956-ffa450edef68
  • Loading branch information
mthl committed Oct 19, 2019
1 parent 4cc9ba8 commit cd130580efb6df97864465e8aba9e7d03e218529
Showing with 1 addition and 0 deletions.
  1. +1 −0 build.gradle
@@ -90,6 +90,7 @@ distributions.main.contents.from(rootDir) {
javadoc {
failOnError = true
options {
source '8'
encoding 'UTF-8'
charSet 'UTF-8'
// Those external Javadoc links should correspond to the actual

0 comments on commit cd13058

Please sign in to comment.
You can’t perform that action at this time.