New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compatibility issue in the latest release #395

Closed
duhengforever opened this Issue Aug 8, 2018 · 1 comment

Comments

Projects
None yet
2 participants
@duhengforever
Member

duhengforever commented Aug 8, 2018

In 4.3.0 release,some client APIs are no longer compatible,especially for some users who have been implemented transactional message. so, users want to be able to restore the previous API to avoid changing the code.
And there's another conflict in the inner topic "TBW102", because this release changed the topic name, it will lead to the old client cannot create topic automatically.

@duhengforever duhengforever changed the title from Compatibility issue to Compatibility issue in the latest release Aug 8, 2018

dongeforever added a commit that referenced this issue Aug 21, 2018

Merge pull request #398 from duhengforever/develop_compatibility_issue
[ISSUE #395]Resolve compatibility issues and keep consistent with the old API
@duhengforever

This comment has been minimized.

Show comment
Hide comment
@duhengforever

duhengforever Aug 31, 2018

Member

Merged!

Member

duhengforever commented Aug 31, 2018

Merged!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment