Skip to content
Permalink
Browse files

[SPARK-27752][CORE] Upgrade lz4-java from 1.5.1 to 1.6.0

## What changes were proposed in this pull request?

This PR upgrades lz4-java from 1.5.1 to 1.6.0. Lz4-java is available at https://github.com/lz4/lz4-java.

Changes from 1.5.1:
- Upgraded LZ4 to 1.9.1. Updated the JNI bindings, except for the one for Linux/i386. Decompression speed is improved on amd64.
- Deprecated use of LZ4FastDecompressor of a native instance because the corresponding C API function is deprecated. See the release note of LZ4 1.9.0 for details. Updated javadoc accordingly.
- Changed the module name from org.lz4.lz4-java to org.lz4.java to avoid using - in the module name. (severn-everett, Oliver Eikemeier, Rei Odaira)
- Enabled build with Java 11. Note that the distribution is still built with Java 7. (Rei Odaira)

## How was this patch tested?

Existing tests.

Closes #24629 from kiszk/SPARK-27752.

Authored-by: Kazuaki Ishizaki <ishizaki@jp.ibm.com>
Signed-off-by: Dongjoon Hyun <dhyun@apple.com>
  • Loading branch information...
kiszk authored and dongjoon-hyun committed May 17, 2019
1 parent fc5bd6d commit 9e0d8c6ce2453e803b55436876820d471f5592b7
Showing with 3 additions and 3 deletions.
  1. +1 −1 dev/deps/spark-deps-hadoop-2.7
  2. +1 −1 dev/deps/spark-deps-hadoop-3.2
  3. +1 −1 pom.xml
@@ -139,7 +139,7 @@ libfb303-0.9.3.jar
libthrift-0.12.0.jar
log4j-1.2.17.jar
logging-interceptor-3.12.0.jar
lz4-java-1.5.1.jar
lz4-java-1.6.0.jar
machinist_2.12-0.6.1.jar
macro-compat_2.12-1.1.1.jar
mesos-1.4.0-shaded-protobuf.jar
@@ -156,7 +156,7 @@ libfb303-0.9.3.jar
libthrift-0.12.0.jar
log4j-1.2.17.jar
logging-interceptor-3.12.0.jar
lz4-java-1.5.1.jar
lz4-java-1.6.0.jar
machinist_2.12-0.6.1.jar
macro-compat_2.12-1.1.1.jar
mesos-1.4.0-shaded-protobuf.jar
@@ -594,7 +594,7 @@
<dependency>
<groupId>org.lz4</groupId>
<artifactId>lz4-java</artifactId>
<version>1.5.1</version>
<version>1.6.0</version>
</dependency>
<dependency>
<groupId>com.github.luben</groupId>

0 comments on commit 9e0d8c6

Please sign in to comment.
You can’t perform that action at this time.