Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix ExtDeprecationWarning (#2137) #2138

Merged
merged 2 commits into from Feb 8, 2017
Merged

Fix ExtDeprecationWarning (#2137) #2138

merged 2 commits into from Feb 8, 2017

Conversation

@asdf2014
Copy link
Member

@asdf2014 asdf2014 commented Feb 8, 2017

Fix ExtDeprecationWarning (#2137)

@asdf2014
Copy link
Member Author

@asdf2014 asdf2014 commented Feb 8, 2017

Why re-check the code, i just amend the commit message for adding the issues code?

Loading

@mistercrunch
Copy link
Member

@mistercrunch mistercrunch commented Feb 8, 2017

I'm fine turning off these warnings. They're coming from the libs we use and therefore they need to fix those. Since our deps are pinned it shouldn't be an issue.

Loading

@mistercrunch mistercrunch merged commit 1edc2b9 into apache:master Feb 8, 2017
4 checks passed
Loading
@asdf2014 asdf2014 deleted the ext_deprecation_warning branch Feb 9, 2017
@asdf2014
Copy link
Member Author

@asdf2014 asdf2014 commented Feb 9, 2017

Yeah, it is.

Loading

@uptonking
Copy link

@uptonking uptonking commented Feb 11, 2017

@asdf2014 @mistercrunch before I merge this commit, superset works fine.. after this commit, I got an error.

Traceback (most recent call last):
  File "/usr/bin/superset", line 6, in <module>
    exec(compile(open(__file__).read(), __file__, 'exec'))
  File "/root/Documents/repos/supersetx/superset/bin/superset", line 8, in <module>
    from flask.exthook import ExtDeprecationWarning
ImportError: cannot import name ExtDeprecationWarning

my env is Pyhton2.7, when I look for ExtDeprecationWarning in `path/to/site-packages/flask/exthook.py, it doesn't exist.
any advice?

Loading

@asdf2014
Copy link
Member Author

@asdf2014 asdf2014 commented Feb 11, 2017

Hi, @uptonking . I use python 2.7.12 and it works for me. Could you run pip freeze command in your venv, show those requirements in comment?

Loading

@asdf2014
Copy link
Member Author

@asdf2014 asdf2014 commented Feb 11, 2017

I think you should reinstall the Flask.
pip freeze | grep Flask

Flask==0.12
Flask-AppBuilder==1.8.1
Flask-Babel==0.11.1
Flask-Cache==0.13.1
Flask-Login==0.2.11
Flask-Migrate==1.5.1
Flask-OpenID==1.2.5
Flask-Script==2.0.5
Flask-SQLAlchemy==2.0
Flask-Testing==0.5.0
Flask-WTF==0.14.2

The requirement ** Flask==0.10 ** does not look good...

Loading

@asdf2014
Copy link
Member Author

@asdf2014 asdf2014 commented Feb 11, 2017

Loading

@uptonking
Copy link

@uptonking uptonking commented Feb 11, 2017

@asdf2014 thanks. superset nice again 👍

Loading

@asdf2014
Copy link
Member Author

@asdf2014 asdf2014 commented Feb 11, 2017

Congratulations! And u r welcome :D

Loading

SalehHindi pushed a commit to SalehHindi/superset that referenced this issue Jun 9, 2017
* fix ExtDeprecationWarning (apache#2137)

* remove warnings.simplefilter from cli.py into superset for PEP (apache#2137)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants