Permalink
Browse files

Explicity list Rampart dependencies to fix Tuscany build issues

git-svn-id: https://svn.apache.org/repos/asf/tuscany/sca-java-2.x/trunk@1441794 13f79535-47bb-0310-9956-ffa450edef68
  • Loading branch information...
1 parent a494bfb commit a7b118a63c0efb76b4e25533b5fd867d476a4ff8 @lresende lresende committed Feb 2, 2013
Showing with 24 additions and 3 deletions.
  1. +24 −3 modules/binding-ws-runtime-axis2/pom.xml
@@ -84,7 +84,7 @@
<dependency>
<groupId>org.apache.rampart</groupId>
<artifactId>rampart-core</artifactId>
- <version>1.5.1</version>
+ <version>1.5.1</version>
<exclusions>
<!--
We can live without most of the Rampart dependencies. The following
@@ -123,6 +123,10 @@
<artifactId>bcprov-ext-jdk15</artifactId>
</exclusion>
<exclusion>
+ <groupId>bouncycastle</groupId>
+ <artifactId>bcprov-jdk15</artifactId>
+ </exclusion>
+ <exclusion>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-jdk14</artifactId>
</exclusion>
@@ -197,10 +201,27 @@
<exclusion>
<groupId>org.apache.santuario</groupId>
<artifactId>xmlsec</artifactId>
- </exclusion>
+ </exclusion>
+ <exclusion>
+ <groupId>org.apache.ws.security</groupId>
+ <artifactId>wss4j</artifactId>
+ </exclusion>
</exclusions>
</dependency>
-
+
+ <dependency>
+ <groupId>bouncycastle</groupId>
+ <artifactId>bcprov-jdk15</artifactId>
+ <version>140</version>
+ </dependency>
+
+ <!-- replace the Rampart wss4j to avoid corrupted jar -->
+ <dependency>
+ <groupId>org.apache.ws.security</groupId>
+ <artifactId>wss4j</artifactId>
+ <version>1.5.10</version> <!--1.6.9-->
+ </dependency>
+
<!-- replace the Rampart xmlsec with the version Tuscany is using -->
<dependency>
<groupId>org.apache.santuario</groupId>

0 comments on commit a7b118a

Please sign in to comment.