Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[ZEPPELIN-3989] Configure IPython Interpreter in Docker image #3303

Closed
wants to merge 1 commit into from

Conversation

Projects
None yet
2 participants
@Leemoonsoo
Copy link
Member

Leemoonsoo commented Feb 4, 2019

What is this PR for?

Configure IPython interpreter in Docker image by installing necessary dependencies.

What type of PR is it?

Improvement

What is the Jira issue?

https://issues.apache.org/jira/browse/ZEPPELIN-3989

How should this be tested?

Build docker image and see if %python interpreter works with Ipython kernel.

Questions:

  • Does the licenses files need update? no
  • Is there breaking changes for older versions? no
  • Does this needs documentation? no
apt-get install -y libpng-dev libfreetype6-dev libxft-dev && \
# for tkinter
apt-get install -y python-tk libxml2-dev libxslt-dev zlib1g-dev && \
pip install numpy && \
pip install matplotlib
pip install numpy==1.12.1 pandas==0.21.1 matplotlib==2.1.1 pandasql==0.7.3 ipython==5.4.1 jupyter_client==5.1.0 ipykernel==4.7.0 bokeh==0.12.10 ggplot==0.11.5 grpcio==1.8.2 bkzep==0.4.0

This comment has been minimized.

@Leemoonsoo Leemoonsoo closed this Feb 4, 2019

@Leemoonsoo Leemoonsoo reopened this Feb 4, 2019

@Leemoonsoo

This comment has been minimized.

Copy link
Member Author

Leemoonsoo commented Feb 7, 2019

Thanks @felixcheung for the review. Merging to master and branch-0.8

@asfgit asfgit closed this in 64a768a Feb 7, 2019

@Leemoonsoo

This comment has been minimized.

Copy link
Member Author

Leemoonsoo commented Feb 7, 2019

Ah branch-0.8 already has 1b6b269. This PR is merged to master only.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.