Permalink
Browse files

Added __init__ to fix submodules issue

  • Loading branch information...
1 parent 2163e1b commit 4beee515da33d8c79237ea629d66f35a81ad9cee @apassant committed Jan 29, 2012
View
@@ -4,3 +4,6 @@
[submodule "mixture/dependencies/seevl"]
path = mixture/dependencies/seevl
url = https://github.com/seevl/seevl-python.git
+[submodule "mixture/dependencies/pyiqe"]
+ path = mixture/dependencies/pyiqe
+ url = https://github.com/iqengines/pyiqe.git
@@ -0,0 +1,3 @@
+from musixmatch import *
+from pyiqe import *
+from rdio import *
Submodule pyiqe added at 57e6fc
No changes.
View
@@ -1,29 +0,0 @@
-# -*- coding: UTF-8 -*-
-
-__all__ = ['Api']
-import apis.api1_2
-STABLE_API_VERSION = "1.2"
-
-def Api(*args, **kwargs):
- """
- This is a thin wrapper around the Actual API Instances.
-
- Usage
- -----
- iqe = Api(API_KEY, API_SECRET, version="1.2")
-
- You can obtain api credentials at http://developer.iqengines.com/accounts/register/
-
- For further information see the docstrings in the following class:
-
- pyiqe.apis.api1_2.Api
-
- """
-
- version = kwargs.pop('version', STABLE_API_VERSION)
-
- api_map = {"1.2" : apis.api1_2.Api}
- if not version in api_map:
- raise Exception("Invalid Api Version")
- ApiClass = api_map[version]
- return ApiClass(*args, **kwargs)
@@ -1,3 +0,0 @@
-# -*- coding: UTF-8 -*-
-
-__all__ = ["api1_2"]
Oops, something went wrong.

0 comments on commit 4beee51

Please sign in to comment.