New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installation troubles #175

Closed
berislavlopac opened this Issue Apr 14, 2015 · 14 comments

Comments

Projects
None yet
3 participants
@berislavlopac

berislavlopac commented Apr 14, 2015

Hi, I've been trying to install dredd on a Ubuntu64 Vagrant box, but when the installation finishes (apparently with no errors apart from some deprecation warnings) the dredd command is not recognised. Any suggestions? Thanks!

@berislavlopac

This comment has been minimized.

Show comment
Hide comment
@berislavlopac

berislavlopac Apr 14, 2015

Update: managed to install dredd, but getting no response from it whatsoever. 😞

berislavlopac commented Apr 14, 2015

Update: managed to install dredd, but getting no response from it whatsoever. 😞

@gonzalo-bulnes

This comment has been minimized.

Show comment
Hide comment
@gonzalo-bulnes

gonzalo-bulnes Apr 14, 2015

Hi @berislavlopac,

Did you install it globally? That requires the -g flag and sudo and is necessary every time you want to be able to use a NPM package from anywhere:

sudo npm install -g dredd

`

gonzalo-bulnes commented Apr 14, 2015

Hi @berislavlopac,

Did you install it globally? That requires the -g flag and sudo and is necessary every time you want to be able to use a NPM package from anywhere:

sudo npm install -g dredd

`

@berislavlopac

This comment has been minimized.

Show comment
Hide comment
@berislavlopac

berislavlopac Apr 14, 2015

Yep, in that second instance. I also installed node and npm separately. Right now any dredd command returns nothing at all, not even an error.

berislavlopac commented Apr 14, 2015

Yep, in that second instance. I also installed node and npm separately. Right now any dredd command returns nothing at all, not even an error.

@gonzalo-bulnes

This comment has been minimized.

Show comment
Hide comment
@gonzalo-bulnes

gonzalo-bulnes Apr 14, 2015

Can you check where Dredd got installed?

which dredd
# should print /usr/bin/dredd

gonzalo-bulnes commented Apr 14, 2015

Can you check where Dredd got installed?

which dredd
# should print /usr/bin/dredd
@berislavlopac

This comment has been minimized.

Show comment
Hide comment
@berislavlopac

berislavlopac Apr 14, 2015

I've got /usr/local/bin/dredd -- perhaps I should install as root rather than via sudo?

berislavlopac commented Apr 14, 2015

I've got /usr/local/bin/dredd -- perhaps I should install as root rather than via sudo?

@gonzalo-bulnes

This comment has been minimized.

Show comment
Hide comment
@gonzalo-bulnes

gonzalo-bulnes Apr 14, 2015

On Ubuntu 14.04 Dredd is indeed installed in /usr/local/bin/dredd (I had checked a 12.01 installation earlier). That's doesn't seem to be the issue.

Could there be any reason for the error output being redirected somewhere in that terminal?
I mean: dredd 2>/dev/null doesn't print anything at all, it's doing its job however.
Since you are running Dredd in a Vagrant box, maybe one of the box settings could be interfering?

gonzalo-bulnes commented Apr 14, 2015

On Ubuntu 14.04 Dredd is indeed installed in /usr/local/bin/dredd (I had checked a 12.01 installation earlier). That's doesn't seem to be the issue.

Could there be any reason for the error output being redirected somewhere in that terminal?
I mean: dredd 2>/dev/null doesn't print anything at all, it's doing its job however.
Since you are running Dredd in a Vagrant box, maybe one of the box settings could be interfering?

@berislavlopac

This comment has been minimized.

Show comment
Hide comment
@berislavlopac

berislavlopac Apr 14, 2015

I'm afraid not, I've just installed dredd on a virgin box, with no additional provisioning, with the same results.

berislavlopac commented Apr 14, 2015

I'm afraid not, I've just installed dredd on a virgin box, with no additional provisioning, with the same results.

@netmilk

This comment has been minimized.

Show comment
Hide comment
@netmilk

netmilk Apr 21, 2015

Contributor

I'm sorry about late response. I think this can be cause by not supported version of node.js. Which version node.js do you use? Dredd currently works only with node.js v0.10.x

$ node -v

Issue about update to node.js 0.12 is here #169

Contributor

netmilk commented Apr 21, 2015

I'm sorry about late response. I think this can be cause by not supported version of node.js. Which version node.js do you use? Dredd currently works only with node.js v0.10.x

$ node -v

Issue about update to node.js 0.12 is here #169

@berislavlopac

This comment has been minimized.

Show comment
Hide comment
@berislavlopac

berislavlopac Apr 21, 2015

I see, this might be the cause -- so is the update mentioned in that issue coming soon?

berislavlopac commented Apr 21, 2015

I see, this might be the cause -- so is the update mentioned in that issue coming soon?

@netmilk

This comment has been minimized.

Show comment
Hide comment
@netmilk

netmilk Apr 21, 2015

Contributor

@berislavlopac I recommend to use Node Version Manager (NVM and install node 10.x as a workaround. Support for 12.x and io.js depends mainly on adding this support to dependant modules.

Contributor

netmilk commented Apr 21, 2015

@berislavlopac I recommend to use Node Version Manager (NVM and install node 10.x as a workaround. Support for 12.x and io.js depends mainly on adding this support to dependant modules.

@netmilk

This comment has been minimized.

Show comment
Hide comment
@netmilk

netmilk Apr 24, 2015

Contributor

@berislavlopac I just released new version of Dredd which should fix this issue. Can you please update Dredd and let me know whether it works for you?

Contributor

netmilk commented Apr 24, 2015

@berislavlopac I just released new version of Dredd which should fix this issue. Can you please update Dredd and let me know whether it works for you?

@berislavlopac

This comment has been minimized.

Show comment
Hide comment
@berislavlopac

berislavlopac Apr 24, 2015

Thanks, I'll take a look next week!

berislavlopac commented Apr 24, 2015

Thanks, I'll take a look next week!

@berislavlopac

This comment has been minimized.

Show comment
Hide comment
@berislavlopac

berislavlopac Apr 28, 2015

Just wanted to let you know that it works great now, thanks! 😃

berislavlopac commented Apr 28, 2015

Just wanted to let you know that it works great now, thanks! 😃

@netmilk

This comment has been minimized.

Show comment
Hide comment
@netmilk

netmilk Apr 28, 2015

Contributor

@berislavlopac Thanks for the information! I'm glad it works.

Contributor

netmilk commented Apr 28, 2015

@berislavlopac Thanks for the information! I'm glad it works.

@netmilk netmilk closed this Apr 28, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment