Skip to content
Commits on Nov 9, 2014
  1. mailmap

    Apocalypse committed Nov 9, 2014
  2. skip dep testing for task

    Apocalypse committed Nov 9, 2014
Commits on Nov 4, 2014
  1. search in bin directory for Dependencies search

    Apocalypse committed Nov 4, 2014
Commits on Nov 1, 2014
  1. suppress undef variable warning

    Apocalypse committed Nov 1, 2014
Commits on Oct 28, 2014
  1. add another perlcritic exclusion for utf8...

    Apocalypse committed Oct 27, 2014
Commits on Oct 25, 2014
  1. New CPAN release of Test-Apocalypse - v1.006

    Apocalypse committed Oct 25, 2014
    	Proper release on CPAN :)
  2. New CPAN release of Test-Apocalypse - v1.005

    Apocalypse committed Oct 25, 2014
    	FakeRelease to test my dzil configs!
  3. New CPAN release of Test-Apocalypse - v1.004

    Apocalypse committed Oct 24, 2014
    	Tweak how we skip/disable plugins because of the recent subtest change, I broke some stuff :(
    	I give up on the Pod::No404s test, the internet is too flaky everywhere :(
    	Removed the OutdatedPrereqs test because I now use Dist::Zilla::Plugin::PromptIfStale, thanks ETHER!
  4. fix reused variable name error, arg

    Apocalypse committed Oct 24, 2014
  5. remove OutdatedPrereqs as I move to DZP::PromptIfStale

    Apocalypse committed Oct 24, 2014
  6. disable 404s test

    Apocalypse committed Oct 24, 2014
  7. Test::Portability::Files is still br0ken :X

    Apocalypse committed Oct 24, 2014
  8. add changelog note

    Apocalypse committed Oct 24, 2014
  9. fix missing Changes commit

    Apocalypse committed Oct 24, 2014
  10. New CPAN release of Test-Apocalypse - v1.003

    Apocalypse committed Oct 24, 2014
    	Add Test::Mojibake to the dist
    	Add more exclusions to the standard Perl::Critic config
    	Add PERL_CRITIC_STRICT env var to skip the bundled Perl::Critic config
    	Fix an error in Test::Apocalypse::Script
    	Use Test::CPAN::Changes instead of the outdated Test::CheckChanges
    	Ripped out the dysfunctional Test::NoWarnings in favor of Test::FailWarnings, thanks DAGOLDEN!
    	Ignore the 'perl' dependency when checking deps
    	Fix version mismatch error when checking dependencies ( 'v0.0.6' vs '0.0.6' )
    	Thanks everyone who sent RT tickets to clean up the FAILs :)
    	Finally enabled the Test::Vars plugin as I've switched over to using subtests instead of Test::Block
  11. update use.perl.org url as it shutdown :X

    Apocalypse committed Oct 24, 2014
Commits on Oct 24, 2014
  1. enable Test::Vars test

    Apocalypse committed Oct 24, 2014
  2. fail kwalitee tests if PERL_APOCALYPSE=1

    Apocalypse committed Oct 24, 2014
  3. add missing check for PERL_APOCALYPSE

    Apocalypse committed Oct 24, 2014
  4. doc tweaks

    Apocalypse committed Oct 24, 2014
  5. tweak Changes to be CPAN::Changes compatible

    Apocalypse committed Oct 24, 2014
  6. fix the perl prereq for good

    Apocalypse committed Oct 24, 2014
  7. fix the Dependency checker

    Apocalypse committed Oct 24, 2014
  8. silence more perlcritic stuff

    Apocalypse committed Oct 24, 2014
  9. Im old and cant change my habits that easily...

    Apocalypse committed Oct 24, 2014
  10. allow warnings from gpg...

    Apocalypse committed Oct 24, 2014
  11. use Test::FailWarnings for less FAIL

    Apocalypse committed Oct 24, 2014
  12. exorcise Test::NoWarnings

    Apocalypse committed Oct 24, 2014
  13. better error reporting for subtests

    Apocalypse committed Oct 24, 2014
  14. dont use Test::Block, use the new subtest feature

    Apocalypse committed Oct 24, 2014
Something went wrong with that request. Please try again.