Permalink
Browse files

native: fix linting issues and update configs

  • Loading branch information...
metagrover committed Jan 9, 2018
1 parent c01556e commit 795dd9354ed1fe98a888d395243c8644f19e1fa8
View
@@ -18,7 +18,6 @@
"eslint": "^4.10.0",
"eslint-config-airbnb": "^16.1.0",
"eslint-plugin-babel": "^4.1.2",
"eslint-plugin-import": "^2.8.0",
"eslint-plugin-jsx-a11y": "^6.0.3",
"eslint-plugin-react": "^7.5.1",
"husky": "^0.14.3"
@@ -0,0 +1,6 @@
{
"extends": "../../../.eslintrc",
"rules": {
"import/no-extraneous-dependencies": 0
}
}
@@ -11,9 +11,14 @@
},
"dependencies": {
"@ptomasroos/react-native-multi-slider": "^0.0.11",
"@storybook/addon-actions": "^3.2.16",
"@storybook/addon-knobs": "^3.2.16",
"@storybook/addon-links": "^3.2.16",
"@storybook/react-native": "^3.2.16",
"appbase-js": "^2.2.2",
"escape-string-regexp": "^1.0.5",
"expo": "22.0.0",
"metro-bundler": "^0.22.1",
"native-base": "^2.3.3",
"react": "^16.2.0",
"react-native": "^0.49.0",
@@ -24,14 +29,9 @@
"xdate": "^0.8.2"
},
"devDependencies": {
"@storybook/addon-actions": "^3.2.16",
"@storybook/addon-knobs": "^3.2.16",
"@storybook/addon-links": "^3.2.16",
"@storybook/react-native": "^3.2.16",
"babel-plugin-module-resolver": "^2.7.0",
"babel-plugin-transform-inline-environment-variables": "^0.2.0",
"babel-preset-expo": "^1.0.1",
"metro-bundler": "^0.20.0",
"prop-types": "^15.6.0",
"react-dom": "^16.1.1",
"react-native-scripts": "0.0.50"
@@ -6,13 +6,9 @@ import { Text, Header, Body, Title } from 'native-base';
import {
ReactiveBase,
DataSearch,
DataController,
TextField,
SingleDropdownList,
MultiDropdownList,
SingleDropdownRange,
MultiDropdownRange,
RangeSlider,
DatePicker,
DateRange,
ReactiveList,
Oops, something went wrong.

0 comments on commit 795dd93

Please sign in to comment.