Can only install SDK up to version 4.0.0.GA #243

Closed
Bostwickenator opened this Issue Apr 29, 2016 · 3 comments

Comments

Projects
None yet
3 participants
@Bostwickenator

Am I missing something here or can you only install SDK up to version 4.0.0.GA. If so there should be a note in the readme of this project (such that it is displayed on the git hub page) noting that the appcelerator SDKs including the titanium ones should now be installed via the https://www.npmjs.com/package/appcelerator package. Even better put this note in the help when you run this CLI's sdk function.

@cb1kenobi

This comment has been minimized.

Show comment
Hide comment
@cb1kenobi

cb1kenobi Apr 29, 2016

Member

It's a little complicated. The available Titanium SDK releases depends on if you're using ti sdk vs appc ti sdk. appc ti sdk shows the latest and greatest SDKs. ti sdk shows the latest release before the switch from the Titanium CLI to the Appcelerator CLI.

The list of releases for the Titanium CLI is no longer automatically updated, but rather it's a manual process. Because we haven't determined which past releases should be available to ti sdk, we simply haven't updated the release list.

However, the list of releases that appc ti sdk reference is automatically updated and current, so I advise you just use appc ti sdk for now.

Member

cb1kenobi commented Apr 29, 2016

It's a little complicated. The available Titanium SDK releases depends on if you're using ti sdk vs appc ti sdk. appc ti sdk shows the latest and greatest SDKs. ti sdk shows the latest release before the switch from the Titanium CLI to the Appcelerator CLI.

The list of releases for the Titanium CLI is no longer automatically updated, but rather it's a manual process. Because we haven't determined which past releases should be available to ti sdk, we simply haven't updated the release list.

However, the list of releases that appc ti sdk reference is automatically updated and current, so I advise you just use appc ti sdk for now.

@cb1kenobi cb1kenobi closed this Apr 29, 2016

@Bostwickenator

This comment has been minimized.

Show comment
Hide comment
@Bostwickenator

Bostwickenator Apr 29, 2016

That's exactly my point I should use appc. However nothing here notes this to people who are used to using the ti cli. You should inform them that the appc package may have a more complete list of SDKs.

That's exactly my point I should use appc. However nothing here notes this to people who are used to using the ti cli. You should inform them that the appc package may have a more complete list of SDKs.

@av-k

This comment has been minimized.

Show comment
Hide comment
@av-k

av-k Nov 21, 2017

Maybe helful,
appc ti sdk install 6.1.2.GA --force
appc ti sdk select
where 6.1.2 your version.

av-k commented Nov 21, 2017

Maybe helful,
appc ti sdk install 6.1.2.GA --force
appc ti sdk select
where 6.1.2 your version.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment