Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installation failure on Ubuntu 18.04.2 LTS #7

Closed
pierreroudier opened this issue Apr 1, 2019 · 2 comments
Closed

Installation failure on Ubuntu 18.04.2 LTS #7

pierreroudier opened this issue Apr 1, 2019 · 2 comments

Comments

@pierreroudier
Copy link

@pierreroudier pierreroudier commented Apr 1, 2019

Hi,

I can't seem to be able to compile under Ubuntu (after installation of all relevant libs, including gdalcubes itself):

> library(devtools)
> install_git("https://github.com/appelmar/gdalcubes_R", args="--recursive")
Downloading git repo https://github.com/appelmar/gdalcubes_R
✔  checking for file ‘/tmp/Rtmpmis6TY/file5d6b6a1998a0/DESCRIPTION’ ...
─  preparing ‘gdalcubes’:
✔  checking DESCRIPTION meta-information ...
─  cleaning src
─  running ‘cleanup’
─  checking for LF line-endings in source and make files and shell scripts
─  checking for empty or unneeded directories
   Removed empty directory ‘gdalcubes/src/gdalcubes’
─  building ‘gdalcubes_0.1.0.tar.gz’
   
Installing package into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)
* installing *source* package ‘gdalcubes’ ...
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config exists... yes
checking pkg-config knows gdal... yes
configure: GDAL_CFLAGS=-I/usr/include/gdal
configure: GDAL_LIBS=-lgdal
checking pkg-config knows proj... yes
configure: PROJ_CFLAGS=
configure: PROJ_LIBS=-lproj
checking pkg-config knows netcdf... yes
configure: NC_CFLAGS=-I/usr/include/hdf5/serial
configure: NC_LIBS=-L/usr/lib/x86_64-linux-gnu/hdf5/serial -lnetcdf -lhdf5_hl -lhdf5 -lpthread -lsz -lz -ldl -lm -lcurl
checking pkg-config knows libcurl... yes
configure: CURL_CFLAGS=-I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu/curl
configure: CURL_LIBS=-lcurl
checking for g++... g++
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C++ preprocessor... g++ -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking iostream.h usability... no
checking iostream.h presence... no
checking for iostream.h... no
configure: Package CPP flags:   -I/usr/include/gdal -I/usr/include/hdf5/serial  -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu/curl -DR_PACKAGE
configure: Package LIBS:  -lgdal -L/usr/lib/x86_64-linux-gnu/hdf5/serial -lnetcdf -lhdf5_hl -lhdf5 -lpthread -lsz -lz -ldl -lm -lcurl -lproj -lcurl
configure: creating ./config.status
config.status: creating src/Makevars
** libs
make: *** No rule to make target 'gdalcubes/src/apply_pixel.o', needed by 'gdalcubes.so'.  Stop.
ERROR: compilation failed for package ‘gdalcubes’
* removing ‘/usr/local/lib/R/site-library/gdalcubes’
Error in i.p(...) : 
  (converted from warning) installation of package ‘/tmp/RtmpAsf3KD/file76ee45403bcb/gdalcubes_0.1.0.tar.gz’ had non-zero exit status

I feel like I should probably point R to the relevant location of the library, but can't quite figure out why.

sessionInfo() output:

R version 3.5.3 (2019-03-11)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 18.04.2 LTS

Matrix products: default
BLAS: /usr/lib/x86_64-linux-gnu/blas/libblas.so.3.7.1
LAPACK: /usr/lib/x86_64-linux-gnu/lapack/liblapack.so.3.7.1

locale:
 [1] LC_CTYPE=en_NZ.UTF-8       LC_NUMERIC=C               LC_TIME=en_NZ.UTF-8       
 [4] LC_COLLATE=en_NZ.UTF-8     LC_MONETARY=en_NZ.UTF-8    LC_MESSAGES=en_NZ.UTF-8   
 [7] LC_PAPER=en_NZ.UTF-8       LC_NAME=C                  LC_ADDRESS=C              
[10] LC_TELEPHONE=C             LC_MEASUREMENT=en_NZ.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] usethis_1.4.0  devtools_2.0.1

loaded via a namespace (and not attached):
 [1] Rcpp_1.0.1        rstudioapi_0.10   magrittr_1.5      pkgload_1.0.2     R6_2.4.0         
 [6] rlang_0.3.2       tools_3.5.3       pkgbuild_1.0.3    sessioninfo_1.1.1 cli_1.1.0        
[11] git2r_0.25.2      withr_2.1.2       remotes_2.0.2     yaml_2.2.0        assertthat_0.2.1 
[16] digest_0.6.18     rprojroot_1.3-2   crayon_1.3.4      processx_3.3.0    callr_3.2.0      
[21] fs_1.2.7          ps_1.3.0          testthat_2.0.1    memoise_1.1.0     glue_1.3.1       
[26] compiler_3.5.3    desc_1.2.0        backports_1.1.3   prettyunits_1.0.2
@appelmar

This comment has been minimized.

Copy link
Owner

@appelmar appelmar commented Apr 3, 2019

Hi, it seems that the git submodule src/gdalcubes has not been cloned correctly. Could you try to install without devtools from the command line?

cd /tmp
git clone --recursive https://github.com/appelmar/gdalcubes_R
R CMD INSTALL gdalcubes_R
@pierreroudier

This comment has been minimized.

Copy link
Author

@pierreroudier pierreroudier commented Apr 3, 2019

@appelmar Thank you so much, that worked.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.