Skip to content
This repository has been archived by the owner. It is now read-only.

PROPFIND with no body on existing collection returns 404 #235

Closed
macosforgebot opened this issue Jul 25, 2008 · 6 comments
Closed

PROPFIND with no body on existing collection returns 404 #235

macosforgebot opened this issue Jul 25, 2008 · 6 comments

Comments

@macosforgebot
Copy link

@macosforgebot macosforgebot commented Jul 25, 2008

helge@… originally submitted this as ticket:298

  • Version: trunk

I'm getting a weird 404 as a response to a PROPFIND. The strange thing is that a PROPFIND from Cadaver works. So I suppose one of the requested properties which triggers the 404? But why is the whole result reported 404 then? Something is fishy ;-)

Its trunk from today.

---snip---
192.168.0.125 - - [25/Jul/2008:14:27:45 +0200] "PROPFIND /calendars/users/user01/ HTTP/1.1" 401 141 "-" "ZideOne/0.8.3 neon/0.27.2" [232.4 ms]
192.168.0.125 - user01 [25/Jul/2008:14:27:45 +0200] "PROPFIND /calendars/users/user01/ HTTP/1.1" 404 113 "-" "ZideOne/0.8.3 neon/0.27.2" [116.5 ms]
192.168.0.125 - user01 [25/Jul/2008:14:27:46 +0200] "PROPFIND /calendars/users/user01/ HTTP/1.1" 404 113 "-" "ZideOne/0.8.3 neon/0.27.2" [29.3 ms]
192.168.0.111 - - [25/Jul/2008:14:29:27 +0200] "PROPFIND /calendars/users/user01/ HTTP/1.1" 401 141 "-" "cadaver/0.23.2 neon/0.27.2" [51.7 ms]
192.168.0.111 - user01 [25/Jul/2008:14:29:33 +0200] "PROPFIND /calendars/users/user01/ HTTP/1.1" 207 3062 "-" "cadaver/0.23.2 neon/0.27.2" [118.1 ms]
---snap---
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Jul 25, 2008

helge@… originally submitted this as attachment:calserver%20bug%20404.txt:⁠ticket:298


Output of CalServer, level debug

@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Jul 27, 2008

helge@… originally submitted this as comment:1:⁠ticket:298


OK, found the issue. CalServer doesn't work with PROPFIND w/o content (content-length: 0). Per WebDAV RFC the behaviour of such is the same like <propfind><all/></propfind>.

When I include the props I actually want, it works like a charm.

Thanks,

Helge

@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Aug 14, 2008

@wsanchez originally submitted this as comment:2:⁠ticket:298

  • Description modified
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Aug 14, 2008

@wsanchez originally submitted this as comment:3:⁠ticket:298

  • Owner changed from @wsanchez to @cyrusdaboo
  • Priority changed from 5: Not set to 3: Important
  • Milestone set to Later
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Aug 14, 2008

@wsanchez originally submitted this as comment:4:⁠ticket:298

  • Summary changed from PROPFIND on existing collection returns 404 to PROPFIND with no body on existing collection returns 404
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Mar 26, 2015

@wsanchez originally submitted this as comment:8:⁠ticket:298

  • Status changed from new to closed
  • Resolution set to Not to be fixed

Expiring old bugs with unknown state and impact.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.