Skip to content
This repository has been archived by the owner. It is now read-only.

Update broken when using setuptools #356

Closed
macosforgebot opened this issue Aug 26, 2011 · 2 comments
Closed

Update broken when using setuptools #356

macosforgebot opened this issue Aug 26, 2011 · 2 comments

Comments

@macosforgebot
Copy link

@macosforgebot macosforgebot commented Aug 26, 2011

mail@… originally submitted this as ticket:461


I have updated my calendar server to current trunk.

However with r8022 the updating broke.

I get now:

2011-08-26 15:59:52+0200 [-] Unhandled error in Deferred:
2011-08-26 15:59:52+0200 [-] Unhandled Error
    Traceback (most recent call last):
      File "/usr/lib/python2.6/site-packages/twisted/internet/defer.py", line 1076, in gotResult
        _inlineCallbacks(r, g, deferred)
      File "/usr/lib/python2.6/site-packages/twisted/internet/defer.py", line 1020, in _inlineCallbacks
        result = g.send(result)
      File "/usr/lib/python2.6/site-packages/txdav/common/datastore/util.py", line 288, in doUpgrade
        yield self.upgradeVersion(actual_version, required_version, dialect)
      File "/usr/lib/python2.6/site-packages/twisted/internet/defer.py", line 1141, in unwindGenerator
        return _inlineCallbacks(None, f(*args, **kwargs), Deferred())
    --- <exception caught here> ---
      File "/usr/lib/python2.6/site-packages/twisted/internet/defer.py", line 1020, in _inlineCallbacks
        result = g.send(result)
      File "/usr/lib/python2.6/site-packages/txdav/common/datastore/util.py", line 310, in upgradeVersion
        upgrades = self.determineUpgradeSequence(fromVersion, toVersion, files, dialect)
      File "/usr/lib/python2.6/site-packages/txdav/common/datastore/util.py", line 364, in determineUpgradeSequence
        raise RuntimeError(msg)
    exceptions.RuntimeError: Missing upgrade file from version 3 with dialect postgres-dialect

I think this is caused by the following snippet from setup.py

                             "txdav.common.datastore": [
                               "sql_schema/*.sql",
                               "sql_schema/*/*.sql",
                             ],
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Aug 26, 2011

@cyrusdaboo originally submitted this as comment:1:⁠ticket:461

  • Status changed from new to closed
  • Resolution changed from to Software changed

Try r8024.

@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Aug 26, 2011

mail@… originally submitted this as comment:2:⁠ticket:461


Thanks for the fast response this fixes the issue.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.