Skip to content
This repository has been archived by the owner. It is now read-only.

Add list of system requirements #69

Closed
macosforgebot opened this issue Nov 3, 2006 · 10 comments
Closed

Add list of system requirements #69

macosforgebot opened this issue Nov 3, 2006 · 10 comments

Comments

@macosforgebot
Copy link

@macosforgebot macosforgebot commented Nov 3, 2006

@cyrusdaboo originally submitted this as ticket:79


We need to add a list of software requirements for the server - specifically things we assume are already installed. e.g., sqllite 3, SVN 1.3 or greater, Python 2.4 or greater, Kerberos, etc.

@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Feb 23, 2007

@wsanchez originally submitted this as comment:1:⁠ticket:79

  • Status changed from new to assigned
  • Priority changed from 4: Nice to have to 1: Blocker
  • Milestone set to Version One
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Jul 30, 2007

@wsanchez originally submitted this as comment:2:⁠ticket:79

  • Milestone changed from 1.0 to 1.1
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Dec 15, 2007

@wsanchez originally submitted this as comment:3:⁠ticket:79

  • Milestone changed from 1.1 to 1.2
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Mar 10, 2008

@wsanchez originally submitted this as comment:4:⁠ticket:79

  • Milestone changed from 1.2 to 1.x
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Oct 28, 2008

@wsanchez originally submitted this as comment:5:⁠ticket:79

  • Milestone changed from CalendarServer-1.x to CalendarServer-2.0
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Mar 23, 2009

macosforge@… originally submitted this as comment:6:⁠ticket:79


Agreed. 'curl' is another dependency.

@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Mar 23, 2009

@wsanchez originally submitted this as comment:7:⁠ticket:79


curl and svn are required for developing the server, not for installing/running it.

@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Mar 24, 2009

macosforge@… originally submitted this as comment:8:⁠ticket:79


Indeed curl might not always be needed, but it's needed when following the instructions on http://trac.calendarserver.org/wiki/QuickStart (for './run -s').

@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Jun 19, 2009

@wsanchez originally submitted this as comment:9:⁠ticket:79

  • Milestone changed from CalendarServer-2.2 to Later
@macosforgebot
Copy link
Author

@macosforgebot macosforgebot commented Feb 4, 2015

@dreness originally submitted this as comment:12:⁠ticket:79

  • Status changed from assigned to closed
  • Milestone changed from Later to CalendarServer-6.x
  • Resolution set to Software changed

The requirements section is the only section of the Admin Guide that is actually complete:

https://trac.calendarserver.org/browser/CalendarServer/trunk/doc/Admin/Guide.rst

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.