German umlauts are not printed #1316

Closed
michaelrsweet opened this Issue Oct 13, 2005 · 9 comments

Comments

Projects
None yet
1 participant
Collaborator

michaelrsweet commented Oct 13, 2005

Version: 1.1.23
CUPS.org User: franz

When I printout the file with embeded courier font, the german umlauts are not printed! When I generate a ps-file with pswrite from ghostscript it is working. There must be something wrong with the pdftops.

I try to generate a ps file using pdftops form 1.2svn but it is also broken. I also tried to get a working ps-file using xpdf 3.00 from SuSE 9.3, but it didn't worked

I am runnig SuSE Enterprise Sever 9 with the SuSE updates!

regards
Franz

Collaborator

michaelrsweet commented Oct 13, 2005

CUPS.org User: franz

I forgot to mention!

With acrobat it viewed and printed!

Collaborator

michaelrsweet commented Oct 13, 2005

CUPS.org User: mike

Please attach the PostScript file you get from pdftops, along with any error/warning messages on the console or in the error_log file.

I just tried this PDF file on my test system and correctly got the umlauts in the output.

Collaborator

michaelrsweet commented Oct 14, 2005

CUPS.org User: franz

The only output of script ->

DEBUG: pdftops - level = 2, width = 595, length = 792

When I do a Xpdf I got the document and the following messages:

Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion

When I try to printout with Xpdf the umlauts are lost!

Collaborator

michaelrsweet commented Oct 14, 2005

CUPS.org User: franz

I checked something more.

I created a pdf file with embeded ttc file SimSun.
When I try to printout the file all my printers crashes (Lexmark Optra T630, Canon iR C 3100 EUR).

when I use the pswrite filter the pdf file is printed out.

Collaborator

michaelrsweet commented Nov 22, 2005

CUPS.org User: mike

Fixed in Subversion repository.

This appears to be fixed by the Xpdf 3.0-based pdftops filter in CUPS 1.2.

Collaborator

michaelrsweet commented Nov 22, 2005

CUPS.org User: franz

I check it next week with the next snapshot.

Thanks a lot!

Collaborator

michaelrsweet commented Nov 27, 2005

CUPS.org User: franz

I compiled and tested -> no difference

I looked for the updates at pdftops and found nothing.

What's happend.

Collaborator

michaelrsweet commented Jan 10, 2006

CUPS.org User: mike

Do you have the Xpdf language packs installed?

Collaborator

michaelrsweet commented Jan 12, 2006

CUPS.org User: franz

Today I try to reproduce the error, I but it was not possible.

With cups 1.2svn r4892 it worked!

The chines documents crashed the printer.

Please close the STR.

I have to open a new one with the chinese Problem!

@michaelrsweet michaelrsweet added this to the Stable milestone Mar 17, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment