New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CUPS does not compile against the 1.2.9 version of libpng . . . #1587

Closed
michaelrsweet opened this Issue Apr 22, 2006 · 2 comments

Comments

Projects
None yet
1 participant
@michaelrsweet
Collaborator

michaelrsweet commented Apr 22, 2006

Version: 1.1.23
CUPS.org User: oadaeh

The 1.2.9 version of libpng has removed several deprecated functions, some of which CUPS uses. I have tested this with the 1.1.23 (the one I normally use) and the 1.2rc2 versions of CUPS.

Here is a link that might be of use:
http://sourceforge.net/mailarchive/message.php?msg_id=12848112

Attached is the compile log from my installation of Source Mage, which includes a copy of the compile output up and the config.log.

@michaelrsweet

This comment has been minimized.

Collaborator

michaelrsweet commented Apr 22, 2006

CUPS.org User: mike

I guess we'll need to set the minimum version of libpng to 1.2 - the newer APIs are not available prior to that... :(

@michaelrsweet

This comment has been minimized.

Collaborator

michaelrsweet commented Apr 22, 2006

CUPS.org User: mike

Fixed in Subversion repository.

@michaelrsweet michaelrsweet added this to the Stable milestone Mar 17, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment