Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

CJKV patch seems break umlaut #1911

Closed
michaelrsweet opened this Issue Aug 14, 2006 · 3 comments

Comments

Projects
None yet
1 participant
Collaborator

michaelrsweet commented Aug 14, 2006

Version: 8.15-current
CUPS.org User: kmuto.debian

Debian GNU/Linux unstable version uses r171 and I received a bug report about missing umlaute.

For example, oauOAU in umlaute.ps have an umlaute, but gs-esp won't show umlaute. gs-gpl or xpdf(after ps2pdf) show correctly.
When I reverted gstype42.c to previous revision, 'oau' showed correct umlaute (but OAU still hadn't).

I believe CJKV patch makes something wrong around a metrics.

Collaborator

michaelrsweet commented Aug 18, 2006

CUPS.org User: JensP

I have uploaded the file "umlaute_fonts.ps" to illustrate how different fonts are rendered. Some have no accents, some have a few and some have them all.

Can anyone confirm this bug?

This problem is rather critical for all people who need to print accented characters!

Cheers

JensP

Collaborator

michaelrsweet commented Aug 20, 2006

CUPS.org User: kmuto.debian

I confirmed.
166:164 revert patch shows umlaute again.

I'd like to hear explains from committer toshi.

Collaborator

michaelrsweet commented Aug 25, 2006

CUPS.org User: mike

Fixed in Subversion repository.

Looks like the new TrueType bounding box loader code isn't quite right - I've #ifdef'd the new code out until we can fix that part, which corrects the rendering of this file...

@michaelrsweet michaelrsweet added this to the Stable milestone Mar 17, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment