New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Don't load the remote cache when CUPS browsing is disabled #2084

Closed
michaelrsweet opened this Issue Nov 7, 2006 · 2 comments

Comments

Projects
None yet
1 participant
@michaelrsweet
Collaborator

michaelrsweet commented Nov 7, 2006

Version: 1.2-current
CUPS.org User: jlovell

Don't load the remote cache when CUPS browsing is disabled. Attached patch fixes it.
Thanks!

@michaelrsweet

This comment has been minimized.

Collaborator

michaelrsweet commented Nov 14, 2006

CUPS.org User: mike

Fixed in Subversion repository.

@michaelrsweet

This comment has been minimized.

Collaborator

michaelrsweet commented Nov 14, 2006

"remote-cache.patch":

Index: dirsvc.c

--- dirsvc.c (revision 6073)
+++ dirsvc.c (working copy)
@@ -160,6 +160,17 @@

/*

  • * Don't load the cache if the CUPS remote protocol is disabled...
  • */
  • if (!(BrowseRemoteProtocols & BROWSE_CUPS))
  • {
  • cupsdLogMessage(CUPSD_LOG_DEBUG,
  •                "cupsdLoadRemoteCache: Not loading remote cache.");
    
  • return;
  • }
  • /*
    • Open the remote.cache file...
      */
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment