Skip to content
Permalink
Browse files

switch swift-tools-version to 5.0 for integration tests (#1369)

Motivation:

Some integration tests still used swift-tools-version:4.0.

Modifications:

Make it 5.0

Result:

Run the compiler in a sensible mode.
  • Loading branch information
weissi committed Jan 29, 2020
1 parent 4a2746c commit 2bf296958b861615d173f1a9e38bbe738d4d995a
@@ -103,7 +103,7 @@ function dir_basename() {

function fake_package_swift() {
cat > Package.swift <<EOF
// swift-tools-version:4.0
// swift-tools-version:5.0
import PackageDescription
let package = Package(name: "$1")
@@ -17,7 +17,7 @@ set -eu

function make_package() {
cat > "$tmpdir/syscallwrapper/Package.swift" <<"EOF"
// swift-tools-version:4.0
// swift-tools-version:5.0
// The swift-tools-version declares the minimum version of Swift required to build this package.
import PackageDescription

0 comments on commit 2bf2969

Please sign in to comment.
You can’t perform that action at this time.