Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[SR-12141] Amplitude @ 4.10.0 isn't building with the new target sources builder #4610

Closed
aciidb0mb3r opened this issue Feb 6, 2020 · 3 comments
Labels

Comments

@aciidb0mb3r
Copy link
Member

@aciidb0mb3r aciidb0mb3r commented Feb 6, 2020

Previous ID SR-12141
Radar rdar://problem/59230517
Original Reporter @aciidb0mb3r
Type Bug
Status Resolved
Resolution Done
Additional Detail from JIRA
Votes 0
Component/s Package Manager
Labels Bug
Assignee None
Priority Medium

md5: 6fa52657076db40de52db9ceffe986bf

Issue Description:

https://github.com/amplitude/Amplitude-iOS @ 4.10.0 isn't building with the new target sources builder.

@aciidb0mb3r
Copy link
Member Author

@aciidb0mb3r aciidb0mb3r commented Feb 6, 2020

@swift-ci create

@slashmo
Copy link

@slashmo slashmo commented Feb 6, 2020

I created a sample project: https://github.com/slashmo/swiftpm-amplitude-bug

It uses a fork of the framework: https://github.com/slashmo/Amplitude-iOS/tree/fix/swift52-support

In AppDelegate.swift, I can import Amplitude but not access any of it's methods/properties.

@aciidb0mb3r
Copy link
Member Author

@aciidb0mb3r aciidb0mb3r commented Feb 27, 2020

#2556
#2555

@swift-ci swift-ci transferred this issue from apple/swift-issues Apr 25, 2022
@shahmishal shahmishal transferred this issue from apple/swift May 4, 2022
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

2 participants