Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[SR-1039] Fetch a dependency with a specified Pre-release version #43651

Closed
swift-ci opened this issue Mar 23, 2016 · 4 comments
Closed

[SR-1039] Fetch a dependency with a specified Pre-release version #43651

swift-ci opened this issue Mar 23, 2016 · 4 comments
Labels
bug A deviation from expected or documented behavior. Also: expected but undesirable behavior.

Comments

@swift-ci
Copy link
Collaborator

swift-ci commented Mar 23, 2016

Previous ID SR-1039
Radar rdar://problem/31214600
Original Reporter kkoval (JIRA User)
Type Bug
Status Resolved
Resolution Done
Additional Detail from JIRA
Votes 0
Component/s Package Manager
Labels Bug
Assignee None
Priority Medium

md5: ddd2bedb694e940bc35ec5193fb2e4e3

is duplicated by:

  • SR-965 How to depend on a specified Pre-release version of package with the Swift Package Manager
  • SR-3657 Dependencies with git-describe style versions are not resolved correctly
  • SR-5192 swiftpm 4 incorrectly resolves prerelease major version as compatible with the current major version

Issue Description:

When a Pre-release version is specified explicitly we should fetch it.

Example:

import PackageDescription

let package = Package(
    name: "App",
    dependencies: [
        .Package(url: "../Foo",  "0.1.0-a")
    ]
)

We should fetch version "0.1.0-a" or fail if there is no such version

@swift-ci
Copy link
Collaborator Author

swift-ci commented Mar 26, 2016

Comment by Kostiantyn Koval (JIRA)

apple/swift-package-manager#223

@aciidb0mb3r
Copy link
Member

aciidb0mb3r commented Mar 21, 2017

This is broken on v3 manifest because we always represent the version in term of ranges, however this is fixed for v4 manifest because we can represent the exact versions properly.

@aciidb0mb3r
Copy link
Member

aciidb0mb3r commented May 25, 2017

@aciidb0mb3r
Copy link
Member

aciidb0mb3r commented May 25, 2017

Stardust bot update:
Repository: https://github.com/apple/swift-package-manager
Branch: master
Commit: 24ddb9c

@swift-ci swift-ci transferred this issue from apple/swift-issues Apr 25, 2022
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug A deviation from expected or documented behavior. Also: expected but undesirable behavior.
Projects
None yet
Development

No branches or pull requests

2 participants