Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Is the google auth actually working/tested? #36

Closed
nhumrich opened this issue Dec 8, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@nhumrich
Copy link

commented Dec 8, 2017

I am trying to set up the google auth for this, and am running into a few problems:

  1. The google token is an access token that expire. Am I expected to update my token every time it expires? or am I doing something wrong? Which token do i copy and paste into my kube/config?

  2. the admin.directory.group scope only works for people who have admin permissions in g suite. If a normal user (non-admin) tries to use this, the groups api call wont work.

Am I doing this wrong or something? Does anyone have google auth working?

@tamalsaha

This comment has been minimized.

Copy link
Member

commented Mar 12, 2018

@nhumrich , sorry this took us a long time to fix. This has been fixed in master. It will be part of the next release.

@tamalsaha

This comment has been minimized.

Copy link
Member

commented Apr 4, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.