New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RDP not working with `image: Visual Studio 2017` #1409

Closed
refack opened this Issue Mar 17, 2017 · 13 comments

Comments

Projects
None yet
4 participants
@refack

refack commented Mar 17, 2017

I'm not able to RDP to workers running image: Visual Studio 2017.
Since it's a new image I'm suspicious...

@IlyaFinkelshteyn

This comment has been minimized.

Show comment
Hide comment
@IlyaFinkelshteyn

IlyaFinkelshteyn Mar 17, 2017

Member

We have some inconsistent behavior with newly added servers which maps to higher port range. Can you please send us non-working port number and if build is still available do not cancel it for us to investigate?

If you already cancelled the build, please retry, it will most probably work next time.

Member

IlyaFinkelshteyn commented Mar 17, 2017

We have some inconsistent behavior with newly added servers which maps to higher port range. Can you please send us non-working port number and if build is still available do not cancel it for us to investigate?

If you already cancelled the build, please retry, it will most probably work next time.

@Thealexbarney

This comment has been minimized.

Show comment
Hide comment
@Thealexbarney

Thealexbarney Mar 20, 2017

I can't connect via RDP even after retrying a few times. I currently have a dummy build running here.

Thealexbarney commented Mar 20, 2017

I can't connect via RDP even after retrying a few times. I currently have a dummy build running here.

@FeodorFitsner

This comment has been minimized.

Show comment
Hide comment
@FeodorFitsner

FeodorFitsner Mar 20, 2017

Member

@Thealexbarney I've been able to RDP into that build - as a proof I deleted text file on desktop to make it continue.

Member

FeodorFitsner commented Mar 20, 2017

@Thealexbarney I've been able to RDP into that build - as a proof I deleted text file on desktop to make it continue.

@Thealexbarney

This comment has been minimized.

Show comment
Hide comment
@Thealexbarney

Thealexbarney Mar 20, 2017

I asked others if they could connect to the build worker, and they couldn't either. I also tried using a different RDP client, and that didn't change anything.
Since you were able to connect to my earlier build after about 50 minutes, I tried waiting that long to see if maybe that changed anything, but it didn't.

Thealexbarney commented Mar 20, 2017

I asked others if they could connect to the build worker, and they couldn't either. I also tried using a different RDP client, and that didn't change anything.
Since you were able to connect to my earlier build after about 50 minutes, I tried waiting that long to see if maybe that changed anything, but it didn't.

@FeodorFitsner

This comment has been minimized.

Show comment
Hide comment
@FeodorFitsner

FeodorFitsner Mar 20, 2017

Member

Please ping me next time you can't connect but don't cancel a build.

Member

FeodorFitsner commented Mar 20, 2017

Please ping me next time you can't connect but don't cancel a build.

@Thealexbarney

This comment has been minimized.

Show comment
Hide comment
@Thealexbarney

Thealexbarney Mar 20, 2017

@FeodorFitsner I've started another dummy build that just runs the enable-rdp script. I'm unable to connect to it.

Thealexbarney commented Mar 20, 2017

@FeodorFitsner I've started another dummy build that just runs the enable-rdp script. I'm unable to connect to it.

@FeodorFitsner

This comment has been minimized.

Show comment
Hide comment
@FeodorFitsner

FeodorFitsner Mar 20, 2017

Member

It worked again for me - I unblocked the build. Maybe that custom 34xxx ports is the problem? Have you tried connecting from other locations?

Member

FeodorFitsner commented Mar 20, 2017

It worked again for me - I unblocked the build. Maybe that custom 34xxx ports is the problem? Have you tried connecting from other locations?

@FeodorFitsner

This comment has been minimized.

Show comment
Hide comment
@FeodorFitsner

FeodorFitsner Mar 20, 2017

Member

Can you please start another build (and check if you can connect) and let me know - I will check from a different location.

Member

FeodorFitsner commented Mar 20, 2017

Can you please start another build (and check if you can connect) and let me know - I will check from a different location.

@Thealexbarney

This comment has been minimized.

Show comment
Hide comment
@Thealexbarney

Thealexbarney Mar 20, 2017

@FeodorFitsner Here's another build.

I just now tried from multiple locations, Internet connections and computers, and none of them have worked.

Thealexbarney commented Mar 20, 2017

@FeodorFitsner Here's another build.

I just now tried from multiple locations, Internet connections and computers, and none of them have worked.

@FeodorFitsner

This comment has been minimized.

Show comment
Hide comment
@FeodorFitsner

FeodorFitsner Mar 20, 2017

Member

Checking...

Member

FeodorFitsner commented Mar 20, 2017

Checking...

@FeodorFitsner

This comment has been minimized.

Show comment
Hide comment
@FeodorFitsner

FeodorFitsner Mar 20, 2017

Member

OK, it looks like this is a firewall issue on our side. We are going to work with our data center to resolve that. Will let here know when it's OK.

Member

FeodorFitsner commented Mar 20, 2017

OK, it looks like this is a firewall issue on our side. We are going to work with our data center to resolve that. Will let here know when it's OK.

@FeodorFitsner FeodorFitsner added this to the 26-Mar-2017 milestone Mar 21, 2017

@FeodorFitsner

This comment has been minimized.

Show comment
Hide comment
@FeodorFitsner

FeodorFitsner Mar 21, 2017

Member

It's been fixed. Sorry for inconveniences.

Member

FeodorFitsner commented Mar 21, 2017

It's been fixed. Sorry for inconveniences.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment