New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

YAML validator doesn't finish if the configuration is a sequence and contains syntax errors #1535

Closed
mknejp opened this Issue May 7, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@mknejp

mknejp commented May 7, 2017

The following string inserted into https://ci.appveyor.com/tools/validate-yaml makes the validation never finish:

- configuration Release

Note that it's a syntax error as the colon after configuration is missing. This seems to only affect YAML files where the root object is a sequence, as the following is correctly reported as an error:

configuration Release

It only seems to affect syntax errors as the following string is processed correctly:

- blaa: Release

@FeodorFitsner FeodorFitsner added the bug label May 8, 2017

@FeodorFitsner FeodorFitsner added this to the 14-May-2017 milestone May 8, 2017

@FeodorFitsner

This comment has been minimized.

Show comment
Hide comment
@FeodorFitsner

FeodorFitsner May 8, 2017

Member

Thanks for the catch! Will be fixed in the next update.

Member

FeodorFitsner commented May 8, 2017

Thanks for the catch! Will be fixed in the next update.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment