Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bundler 2.0 for Ruby >= 2.3, Bundler 1.17.3 for all Rubies #2829

Closed
FeodorFitsner opened this Issue Jan 28, 2019 · 5 comments

Comments

Projects
None yet
4 participants
@FeodorFitsner
Copy link
Member

FeodorFitsner commented Jan 28, 2019

@FeodorFitsner FeodorFitsner changed the title Bundler 2.0 for Ruby 2.3+, Bundler 1.17.3 for Ruby 2.2- Bundler 2.0.1 for Ruby 2.3+, Bundler 1.17.3 for Ruby 2.2- Jan 28, 2019

@FeodorFitsner FeodorFitsner changed the title Bundler 2.0.1 for Ruby 2.3+, Bundler 1.17.3 for Ruby 2.2- Bundler 2.0.1, Bundler 1.17.3 for Ruby 2.2.6 only Jan 28, 2019

@FeodorFitsner FeodorFitsner changed the title Bundler 2.0.1, Bundler 1.17.3 for Ruby 2.2.6 only Bundler 2.0.1 for all Ruby versions except 2.2.6, Bundler 1.17.3 for Ruby 2.2.6 only Jan 28, 2019

@FeodorFitsner FeodorFitsner changed the title Bundler 2.0.1 for all Ruby versions except 2.2.6, Bundler 1.17.3 for Ruby 2.2.6 only Bundler 2.0 for Ruby >= 2.3, Bundler 1.17.3 for Ruby < 2.2 Jan 28, 2019

@larskanis

This comment has been minimized.

Copy link

larskanis commented Jan 31, 2019

You should pre-install both bundler-1.17.x and bundler-2.x on Ruby >= 2.3. This can be done like so:

gem install --no-document bundler "bundler:~>1.17"

This is because many projects still have a Gemfile.lock which is tagged to bundler-1.x, which bundler-2.x can not handle. However in this case bundler-1.x is automatically invoked. So installing both solves this issue. This works even on Ruby-2.6, which includes bundler-2.x by default.

@FeodorFitsner

This comment has been minimized.

Copy link
Member Author

FeodorFitsner commented Jan 31, 2019

Nice catch, thank you!

@FeodorFitsner FeodorFitsner changed the title Bundler 2.0 for Ruby >= 2.3, Bundler 1.17.3 for Ruby < 2.2 Bundler 2.0 for Ruby >= 2.3, Bundler 1.17.3 for all Rubies Jan 31, 2019

@MSP-Greg

This comment has been minimized.

Copy link

MSP-Greg commented Feb 4, 2019

RubyGems 3.0.2 includes Bundler 1.17.3. So, one could also update RubyGems, then install Bundler 2.x via:

gem install --no-document bundler "bundler:>=2.0"
@FeodorFitsner

This comment has been minimized.

Copy link
Member Author

FeodorFitsner commented Feb 4, 2019

Yep, this is what we did. Thanks for the heads up!

@IlyaFinkelshteyn

This comment has been minimized.

Copy link
Member

IlyaFinkelshteyn commented Feb 12, 2019

New Windows images deployed

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.