Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Python stack is not working on macos image #3213

Closed
FeodorFitsner opened this issue Nov 22, 2019 · 5 comments
Closed

Python stack is not working on macos image #3213

FeodorFitsner opened this issue Nov 22, 2019 · 5 comments
Labels
bug

Comments

@FeodorFitsner
Copy link
Member

@FeodorFitsner FeodorFitsner commented Nov 22, 2019

From the original report:

Enabling Python 2.7.16
/usr/local/Cellar/appveyor-build-agent/7.0.2546/bash-shell.sh: line 62: /Users/appveyor/venv2.7.16/bin/activate: No such file or directory
Error enabling 'python' stack: Command exited with code 1

According to https://www.appveyor.com/docs/macos-images-software/#python the image should have v2.7.17, so I modified my appveyor.yml file to specify 2.7.17 but then I get this error instead:
Error enabling 'python' stack: Python version not found: 2.7.17. Available Python versions: 2.6.9, 2.7.16, 3.4.9, 3.5.7, 3.6.8, 3.7.0, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.8.0

@joachimmetz

This comment has been minimized.

Copy link

@joachimmetz joachimmetz commented Dec 2, 2019

It looks like stack only works on linux images.

For a work-around after some experimentation

  • python gives me 2.7.10
  • python3 gives me 3.7.5

though invoking python3 does not seem to work all the time, instead invoke /usr/local/bin/python3.7 directly (not 100% sure if that is reliable yet)

@jacobq

This comment has been minimized.

Copy link

@jacobq jacobq commented Dec 5, 2019

It looks like stack only works on linux images.

Shouldn't it be ignored by other images then? For example, it doesn't seem to cause a problem on Visual Studio 2017. Should I be setting it inside of for then?

@joachimmetz

This comment has been minimized.

Copy link

@joachimmetz joachimmetz commented Dec 5, 2019

@jacobq I don't know, just put my observations here.

@jacobq

This comment has been minimized.

Copy link

@jacobq jacobq commented Jan 23, 2020

@FeodorFitsner I hate to be a nag and post an "Is there any update on this?" comment, but it's been a few months of silence, and this problem is preventing me from using the MacOS images to build our app in CI. Are there any public links you can share regarding work that's being/been done on these images or this particular problem?

@Wasapl Wasapl added the in progress label Jan 28, 2020
Harmon758 added a commit to Harmon758/Harmonbot that referenced this issue Feb 3, 2020
Python stack does not work with macos image:
appveyor/ci#3213
@Wasapl Wasapl removed the in progress label Feb 28, 2020
@Wasapl Wasapl closed this Feb 28, 2020
@jacobq

This comment has been minimized.

Copy link

@jacobq jacobq commented Feb 28, 2020

🎉 Thank you! 🙏 🥂 🚀

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants
You can’t perform that action at this time.