Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
206 lines (191 sloc) 7.61 KB
layout title
docs
Software pre-installed on macOS build VMs

Software pre-installed on macOS build VMs

{:.no_toc}

  • Comment to trigger ToC generation {:toc}

The history of macOS image updates can be found here.

<!-- Version control systems -->
<tr>
    <th id="version-control-systems" class="section" colspan="3">Version control systems</th>
</tr>
<tr>
    <td>Git 2.24.0</td><td class="yes"></td><td class="yes"></td>
</tr>
<tr>
    <td>Git Large File Storage (Git LFS) 2.8.0</td><td class="yes"></td><td class="yes"></td>
</tr>
<tr><td>Mercurial 5.2</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Subversion 1.13.0</td><td class="yes"></td><td class="yes"></td></tr>

<!-- XCode -->
<tr>
    <th id="xcode" class="section" colspan="3">XCode</th>
</tr>
<tr><td>XCode 11.2.1</td><td class="yes"></td><td class="yes"></td></tr>

<!-- .NET Framework -->
<tr>
    <th id="net-framework" class="section" colspan="3">.NET Framework</th>
</tr>
<tr><td>.NET Core SDK 2.1.202</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>.NET Core SDK 2.1.802</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>.NET Core SDK 2.2.402</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>.NET Core SDK 3.0.100</td><td class="yes"></td><td class="yes"></td></tr>

<!-- Node.js -->
<tr>
    <th id="node-js" class="section" colspan="3">Node.js</th>
</tr>
<tr><td>Node Version Manager (<code>nvm</code>) 0.35.0</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 4.9.1</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 5.12.0</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 6.17.1</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 7.10.1</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 8.16.2</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 9.11.2</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 10.17.0</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 11.15.0</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 12.13.1</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Node.js 13.1.0</td><td class="yes"></td><td class="yes"></td></tr>

<!-- Java -->
<tr>
    <th id="java" class="section" colspan="3">Java</th>
</tr>
<tr><td>AdoptOpenJDK 8,232</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>AdoptOpenJDK 9,181</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>AdoptOpenJDK 10.0.2</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>AdoptOpenJDK 11.0.5</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>AdoptOpenJDK 12.0.2</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>AdoptOpenJDK 13.0.1</td><td class="yes"></td><td class="yes"></td></tr>
<!-- Go -->
<tr>
    <th id="golang" class="section" colspan="3">Go (Golang)</th>
</tr>
<tr><td>Go Version Manager (<code>gvm</code>) v1.0.22</td><td class="yes"></td><td class="yes"></td></tr>
<tr>
    <td>
        <ul>
            <li>Go 1.7.6</li>
            <li>Go 1.8.7</li>
            <li>Go 1.9.7</li>
            <li>Go 1.10.8</li>
            <li>Go 1.11.13</li>
            <li>Go 1.12.13</li>
            <li>Go 1.13.4</li>
        </ul>
    </td>
    <td class="yes"></td><td class="yes"></td>
</tr>

<!-- Ruby -->
<tr>
    <th id="ruby" class="section" colspan="3">Ruby</th>
</tr>
<tr><td>Ruby Version Manager (<code>rvm</code>) 1.29.9<br><br>Switching between Ruby versions: <code>rvm use &lt;version&gt;</code></td><td class="yes"></td><td class="yes"></td></tr>
<tr>
    <td>
        <ul>
            <li>Ruby 2.0.0-p648</li>
            <li>Ruby 2.1.10</li>
            <li>Ruby 2.2.10</li>
            <li>Ruby 2.3.8</li>
            <li>Ruby 2.4.6</li>
            <li>Ruby 2.6.3 (default)</li>
            <li>Ruby 2.7.0-preview1</li>
            <li>Ruby head</li>
        </ul>
    </td>
    <td class="yes"></td><td class="yes"></td>
</tr>

<!-- Python -->
<tr>
    <th id="python" class="section" colspan="3">Python</th>
</tr>
<tr>
    <td>
        <ul>
            <li>Python 2.6.9</li>
            <li>Python 2.7.17</li>
            <li>Python 3.4.9</li>
            <li>Python 3.5.9</li>
            <li>Python 3.6.9</li>
            <li>Python 3.7.5</li>
            <li>Python 3.8.0</li>
            <li>virtualenv 16.7.5</li>
            <li>pip 19.2.3</li>
        </ul>
    </td>
    <td class="yes"></td><td class="yes"></td>
</tr>

<!-- Compilers -->
<tr>
    <th id="compilers" class="section" colspan="3">Compilers</th>
</tr>
<tr><td>CMake 3.16.0-rc3</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>GCC 6.5.0</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>GCC 7.4.0</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>GCC 8.3.0</td><td class="yes"></td><td class="yes"></td></tr>

<!-- Simulators -->
<tr>
    <th id="simulators" class="section" colspan="3">Simulators</th>
</tr>
<tr><td>iOS 12.4</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>tvOS 12.4</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>watchOS 5.3</td><td class="yes"></td><td class="yes"></td></tr>

<!-- Tools -->
<tr>
    <th id="tools" class="section" colspan="3">Tools</th>
</tr>
<tr><td>Brew 2.1.16</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>Fastlane 2.28.3</td><td class="yes"></td><td class="yes"></td></tr>
<tr><td>curl 7.67.0</td><td class="yes"></td><td class="yes"></td></tr>
Software installed / Build worker image macos macos-mojave
Operating system
macOS 10.15 "Catalina"
macOS 10.14 "Mojave"
PowerShell
PowerShell Core 6.2.3
You can’t perform that action at this time.