Publish update fails on published empty multi-component repo #66

Closed
scarytom opened this Issue Jun 11, 2014 · 2 comments

Comments

Projects
None yet
2 participants
@scarytom

I used aptly 0.6 to publish a multi-component repo from two empty local repos. I then tried to run publish update and got:

ERROR: unable to update: lstat /home/user/.aptly/public/pool/stable: no such file or directory

Here are the commands I ran:

aptly repo create -distribution=all -component=stable   all_stable
aptly repo create -distribution=all -component=unstable all_unstable
aptly publish repo -skip-signing -component=stable,unstable all_stable all_unstable
aptly publish update -skip-signing all

@smira smira added the bug label Jun 11, 2014

@smira smira added this to the v0.7 milestone Jun 11, 2014

@smira

This comment has been minimized.

Show comment
Hide comment
@smira

smira Jun 11, 2014

Member

Thanks for the bug report!

Error is harmless, though... It would go away once you would publish at least one package in each component.

Member

smira commented Jun 11, 2014

Thanks for the bug report!

Error is harmless, though... It would go away once you would publish at least one package in each component.

@smira

This comment has been minimized.

Show comment
Hide comment
@smira

smira Jun 11, 2014

Member

Fixed in master.

Member

smira commented Jun 11, 2014

Fixed in master.

@smira smira closed this Jun 11, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment