New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"ERROR: unable to update: local repo with uuid ..... not found" #804

Closed
Daniel15 opened this Issue Jan 10, 2019 · 1 comment

Comments

Projects
None yet
1 participant
@Daniel15
Copy link

Daniel15 commented Jan 10, 2019

Detailed Description

I have a repo stored in a Git repo (https://github.com/yarnpkg/releases/tree/gh-pages/debian-source). I can update it fine on my laptop (Aptly 1.3.0, running on Ubuntu via Windows Subsystem for Linux), but when I try to update it on my production build server, I get this error:

+ aptly -config=./.aptly.conf publish update -gpg-key=23E7166788B63E1E stable
ERROR: unable to update: local repo with uuid cf9b0d68-8463-4589-85ab-302e81ac6147 not found

The file are identical across both (latest version of the Git repo), so I'm not sure why it's only broken in one environment.

Your Environment

Debian buster (testing)
Aptly 1.3.0

Daniel15 added a commit to yarnpkg/releases that referenced this issue Jan 10, 2019

@Daniel15

This comment has been minimized.

Copy link

Daniel15 commented Jan 11, 2019

Fixed by uninstalling Aptly from the Debian repo, then reinstalling from Aptly's repo (repo.aptly.info). I guess there was a conflict in library versions, or something like that.

@Daniel15 Daniel15 closed this Jan 11, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment