Skip to content
An Objective-c/Cocoa library that provides Software Transactional Memory capabilities as found in Clojure.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
CTKConcurrency.xcodeproj
Classes
CTKConcurrency.m
CTKConcurrency_Prefix.pch
Eclipse Public License -v 1.0.html
README

README

/*
 * Author: Alejandro M. Ramallo
 * Copyright (c) Alejandro M. Ramallo. All rights reserved.
 *
 * The use and distribution terms for this software are covered by the
 * Eclipse Public License 1.0 <http://opensource.org/licenses/eclipse-1.0.php>
 * which can be found in the file epl-v10.html at the root of this distribution.
 * By using this software in any fashion, you are agreeing to be bound by
 * the terms of this license.
 * You must not remove this notice, or any other, from this software.
 *
 * The work contained herein is derived from and in many places is a direct translation 
 * of Clojure distribution <http://clojure.org/>. That work contains the following notice:
 *
 *   -----------------------------------------------------------------------------
 *   Clojure
 *   Copyright (c) Rich Hickey. All rights reserved.
 *   The use and distribution terms for this software are covered by the
 *   Eclipse Public License 1.0 (http://opensource.org/licenses/eclipse-1.0.php)
 *   which can be found in the file epl-v10.html at the root of this distribution.
 *   By using this software in any fashion, you are agreeing to be bound by
 *   the terms of this license.
 *   You must not remove this notice, or any other, from this software.
 *   -----------------------------------------------------------------------------
 */

Blog: http://comingthoughts.com

Documentation: Look at http://wiki.github.com/aramallo/CTKConcurrency/

CTKConcurrency is an library to provide Software Transactional Memory capabilities as found in Clojure, to the Objective-C/Cocoa platform.

It only works with Intel 64-bit macs of far.

The project contains an executable with a basic test using GCD so you will need Snow Leopard.

Something went wrong with that request. Please try again.